Weird behaviours with outlook 2016 and last releae of wpg4win (3.1.10)

Hi everybody,
I hope you can help me with these 2 strange beaviours I have since I updated the gpg software:

  1. every time I open Outlook an exchange window pops out (see attach 1). This is just boring but it is not a problem per se.

  2. some of the emails I receive from my colleagues are just truncated. I can only read the first or second line ant then it is truncated with random letters.
    I notice this happens if the sender didn’t sign his email.
    This is a real issue, in fact I can’t read entire emails…

Is it a bug?


I enabled the logging and then grabbed the message from the log, then I pasted it in the Kleopatra notepad and then decoded and it is perfectly readable…
So why doesn’t Outlook show correctly the email?

The message decrypted was:

"Ciao Tizio, Ciao Sempronio,

ho letto l’NDA e riporto quanto ho capito."

The message shown by outlook is:

"Ciao Tizio, Ciao Sempronio,

ho letto lb"

Could it be there’s a bug in the GPGOL with the character " ’ " ?

Did another test, apparently it trunks and substitutes the " ’ " with a " b "
what the hell?

Sounds very strange indeed.

First the exchange window, I do not think that this can come from GpgOL. GpgOL does nothing related to that. Have you tried disabling GpgOL to check if the Problem still exists?

Another thing you can try is to disable all other COM Addins except GpgOL and check if the weird behavior still exists.

GpgOL should also not do anything to unsigned / non crypto mails. Or did you mean unsigned as in encrypted but not signed?

In this very moment I disabled all the addins, even GPGOL, and outlook opens without the dialog window, so it is definetly GPGOL the issue.
In fact, if I open Outlook without the GPGOL Addins enabled I don’t see the window and if enable it the dialog windows pops out immediatly, even if Outlook it is still running.

GpgOL should also not do anything to unsigned / non crypto mails. Or did you mean unsigned as in encrypted but not signed?

I meant crypted and not signed.

Moreover I tried to find if the email I can’t decrypt has something wrong (charset of text format) and it hasn’t…

Update: it seems GPGOL truncates emails (or don’t decrypt at all) in case of symbols like " ’ " or characters like “à” “è” “ò” and so on.

This is very annoying…Is there any fix for this?

No, as we don’t understand the problem yet there is no fix. We have not received reports from other users with this issue.

What is your language setting in Outlook and Windows?

Which client are your communication partners using?

I’am using Italian and English as you can see in the attachment.

I just received an email saying (I had to watch the email on a colleague computer):

“Il contenuto di questa e-mail e degli eventuali allegati è rivolto unicamente alla persona o all’organizzazione etc etc”

GPGOL decrypts only as:

“Il contenuto di questa e-mail e degli eventuali allegati C( rivolto unicamente alla persona o allb”

More informations:

  • the message is encrypted and not signed.
  • if I disable GPGOL I get the unencrypted message, of course, but if I copy/paste it on Kleopatra notepad and then I try to decode it I get this error (translated): “Unable to determine if this is a signature or a ciphertext S / MIME or OpenPGP; perhaps it is neither a ciphertext nor a signature?”

The email, actually, is ciphertext of course.

How can I support you more in order to fix this?


Regarding how to best help with this:

Could you please ask your collegue to send a similar message to ?

Key is here:



You should have received an email with subject “support GPG”

FYI: colleague uses gpg4win 2.3.4 and office 2016

ARGH! So many Bugs in 2.3.4 that have been fixed. I’m not even sure if that could send PGP/MIME or just sent PGP/Inline (which can’t handle encoding like foô or whatever properly.

That is likely the problem. Please get him to update at least to 3.1.9 if 3.1.9 worked for you. Better to 3.1.10.

2.3.4 has security issues and the GpgOL in there is ~200 person days of developers behind the current state.

Really 2.x Versions of Gpg4win are fully end of life and unsupported. Sadly they do not even have the update reminder when starting Kleopatra as we only added that in 3.x

Ok I understand it should be better to upgrade to the last version but in this way nobody will be able to read old email if those have those strange characters in the body…This is really bad :frowning:

Thank you for your support

No sorry. But we cannot fix it with a newer Gpg4win Version if the Bug is in the old Gpg4win Version.

So I cannot tell you yet if the bug is on the senders side or on your side. But not updating a security software for years is just bad update policy.

Are you sure the issue is on the old version?
I am able to open and decrypt email with other softwares, on android an iOS for example…

Hi Gianni,

the last problem you are writing about seems to be an encoding issue.
You maybe able to manually convert the old email’s contents to the right encoding,
if you find out what the sending encoding was. This is one of the drawbacks of
no-mime OpenPGP emails (which some people call too positively ‘inline’).
It may work with some combinations of software (and settings), but may not work later
or with different software.

As Andre wrote: It is important to update the sending software to a more current version as soon as possible for several reasons. One is that it is using OpenPGP/MIME which handles encoding a lot better! :slight_smile:

If the emails are very precious, you could contract an IT consultant to check on the encoding and find a way to decode it.

Best Regards,

Good morning and thank you for your kind answer.
I agree a lot about updating all the software, but as I said we would have issues decoding old email sent with 2.3.4.
The only way we found is to copy/paste the encoded mail in some software (unfortunatly Kleopatra notepad tool included in 3.1.10 doesn’t work) and then save the decrypted email.

Anyway, any hints regarding the dialog windows that appears any time you start outlook?

Thank you very much for your effort


instead of paste and copying you should also be able to save the file on the disk and use the command line (gpg --decrypt) to get a file. Once you know which encoding it is, you could transfer it with a different tools.

Regarding the dialouges: I did not read this in detail.

How does Kleoapatra’s notepad not work for you? We would be interested to fix that, too. But for me and others there is no issue with the Notepad in 3.1.10, it works.