[works again] GpgOL Decrypt Error on Office 365 (Build 9126.2152 Click to Run)

Using the gpg4win-3.1.0 and after entering my password in the PinEntry dialog, Outlook 365 produced an error stating an OpenPGP Encrypted message (decryption not possible). Could not decrypt the data: Invalid crypto engine.

This worked under the previous version of Gpg4win (3.03).

I have rebooted as well as unloaded and loaded the gpgol.dll COM file from within Outlook.


I tried changing to the gpgol.dll in the bin_64 directory but the file was reported as not a valid Office Add-in.


It still works on my GS7 Edge phone…

Sorry all. I don’t know why/how but it is working today. I rebooted prior getting the errors that I posted screen shots of so I do not know what changed today other than a shutdown versus reboot. Probably has something to do with artifacts in my Win10 OS. Feel free to lock/delete this entire thread, unless someone else had similar problems. I can’t see how to delete or lock the thread.

Hi James,

good to know it is working fine for you!

As we appreciate all feedback, thanks for getting out and writing something up.
It’s perfectly fine to have this in the tracker, if that’s okay for you.
Later this may be of interest to someone.
(I’ve placed a ‘[works again]’ note in the subject.)

Best Regards,

When I initially installed the new release, I didn’t have the “GpgOL decrypt error”, but once it showed up after a few more tests it showed up and hasn’t gone away. I am now aware the developers know of the bug, but I do find it strange that it worked at first and now, even with the usual complete power downs, etc. it’s here to stay. Looking forward to the new release and sincere thanks to the developers who dedicate so much time and effort for the community.

For the record, my system (works now) is:

Windows Surface Pro 2 (4.00 GB, Intel Core i5-4200U CPU @ 1.6 GHz 2.30 GHz)
Windows 10 Pro v1709 (OS Build 16299.371)
Gpg4win v3.1.0

Dear Danny,
a decryption “error” is some sort of general fallback, so we cannot be sure what the cause is.
There are many other factors in an operating system that could cause decryption to fail like no space on the filesystem (to state a simple one). Not all of them are caused by Gpg4win and many cannot be directly diagnosed by it.

If you are still having problems, if you can, try to do crypto operations on the command line for more diagnostic purposes, e.g. see https://wiki.gnupg.org/TroubleShooting

Best Regards,