WinSCP doesn't detect "paegant" even though gpg-agent is running

I am using my Yubikey as a gpg key, and have successfully set up gpg so that I can use my yubikey to authenticate my ssh logins It all works nicely.

I tried to replicate the same thing in a windows VM but I cannot get WinSCP to detect “pageant”.

My gpg-agent.conf contains “enable-putty-support”. my gpg.conf contains “enable-ssh-support”.

I have a batch file that executes this at logon:

gpg-connect-agent killagent /bye
gpg-connect-agent /bye

Yet WinSCP doesn’t detect it.

Any ideas?

Hi Bob,

so it is working on a GNU/Linux system, but not on windows (is what I’ve understood).

Because of some peculiarities how Windows and some development systems for Windows implement socket connections, there are some combinations that do not simply work.
If you look at there should be a few hints to make more work.
(Make sure you also blend in the fully history of the ticket.)

Let us know if this helped.


Ack! I’m sorry, I wasn’t clear. Because this was a gpg4win forum I assumed I didn’t have to specify I was running on Windows.

So, no, my non-vm Workstation is windows 10 pro.

The VM I am trying to get it working on is also windows 10 pro.

Thanks for the link, I’ll check it out.

No problem, sometimes people use several systems and want to make something that works on a different system also working on windows. :slight_smile:

If it works on one Windows installation, but not on the other, there must a be a difference in the setup that you need to find.

Yes, I think you were right, but I don’t know exactly what the problem is.

However, I have solved the problem.

I ended up removing all traces of gnupg4win and gnupg, then installing only gnupg using chocolatey. Then I installed win-gpg-agent from:

I found a reference to that on this forum.

Once I connected my keys to gnupg and ran win-gpg-agent, everything worked perfectly.