WinPT can't configure self

I am running Windows XP (SP2). I just installed gpg4win 2.0.3 from, ran through the installation, and I am encountering the following problems with WinPT:

  1. It did not show up in the Start Menu folder under Gpg4Win; I had to add it myself.

  2. Whenever I run it, it pops up a dialog saying “Could not find the GPG binary (gpg.exe). Do you want to start the GPG preferences to correct this problem?” I click [Yes].

GnuPG preferences pops up. The first text box is for the home directory, where keyrings are located. It is set to H:\Application Data\gnupg. It is not changeable, though I would very much like to change that, as it is on a network share.

But anyhow. I click on the [Browse] button for GnuPG exe file location, and I navigate to C:\Program Files\GNU\GnuPG\pub\gpg.exe. I click [OK].

The GnuPG preferences dialog pops up again, with the exe file location box blank. I again click the [Browse] button and select gpg.exe, and click [OK].

WinPT asks me if I want to copy my keyrings from another location or create a new key pair. I choose “copy from another location”. I navigate to where pubring.gpg and secring.gpg are, and select them in turn.

Then WinPT displays an error dialog: “Could not read GnuPG version.” and craps out. If I try to run it again, I have to start all over from the beginning, with the same results.

I’m getting a similar problem. I’m running Windows XP (SP3). After installing gpg4win 2.0.4 I found I did not have WinPT, so I downloaded it.

When I run WinPT, up pops the dialog “Could not find the GPG binary (gpg.exe). Do you want to start the GPG preferences to correct this problem?”. I click “Yes”.

Next I get an error message saying “The procedure entry point WNetEnumCachedPasswords could not be located in the dynamic link library MPR.dll”. I click “OK”.

Now I get the GnuPG preferences dialog. I click “Browse” and navigate to C:\Program Files\GNU\GnuPG\pub\gpg.exe", then click “OK”.

The response is an error message: “Invalid crypto engine”. I click “OK” and the WinPT software ends.

Any advice much appreciated!

Problem solved. The ReadMe file that comes with gpg4win states that WinPT is no longer used by GPG. Kleopatra, which installs with gpg4win, is used for message encryption/decryption instead.

Users beware: the Novice Manual (English), which says to use WinPT, is out of date.

If you can’t get Kleopatra to decrypt messages (I couldn’t), then download the Firefox add-on ‘FireGPG’ instead. Really simple to use, not only with Gmail but with Fastmail too. Your email client will automatically recognise that a message is encrypted and you just have to click on a ‘Decrypt’ link to decrypt it. When you first setup FireGPG, it may ask you where to look for GnuPG. Its at C:\Program Files\GNU\GnuPG\pub\gpg.exe (if you installed gpg4win to the default location).