windows 8.1 saving gpg42win privkey passphrase in memory

I’m using gpg4win 2.2.1 on windows 8.1.

I decrypt a doc with this cmd on the command line:

gpg -d doc.txt

I get a pop up from kleopatra asking for the passphrase for my key and the document is decrypted.

I exit and reopen the shell and I’m able to replay the cmd WITHOUT entering the passphrase.

I can not figure out how to remove my passphrase from memory.

Any suggestions?

Also does it bother anyone else the CA for this website is not trusted ?

Thank you.

the passphrase (PIN) was being cashed by Kleopatra.

in Kleopatra go to

Configure Kleopatra
select GnuPG System (gold lock) on left.
select GPG agent tab
Under “Options controlling the security”
you can select time in second to expire cache for both PIN (passphrase) and ssh key.

Hi all,

I am using the current version of gpg4win(v2.2.3) and kleopatra(v2.2.0) under windows 7.

I am not prompted for a passphrase, but I get the response “wrong passphrase entered”, either signing a file or decrypting a file.

I do not have the tab “GPG agent” and I can’t find the “Options controlling the security” in any other tab. Furthermore no option to define expiration time of PIN or ssh key in the tabs.

Is there any alternative to “clear the passphrase cache”?

Many Thanks,