Symmetric Encryption to Terminal

Hello. I am having problems encrypting symmetrically to terminal with Gpg4Win. I know this works with recipients in public key encryption but the symmetrical option appears to fail. I have tried leaving a line between text entry and one or more carriage return lines afterward with varying results but without any apparent pattern. Pasting text in never works. Searching on search engines for the appropriate commands has also not helped.
I enter:

gpg2.exe -a -c
[password prompt]

Intended text of any length or line breaking…


This sometimes gives an encrypted output and often doesn’t. Anyone have any insight here?

I just tried to reproduce this with a Windows 10 64bit machine, but wasn’t able to. It works fine with your described workflow.
Can you give us your gpg version (gpg --version)? What kind of Command Shell do you use? What Windows version do you have?

I am indeed using Windows 10 64 bit. The gpg version is gpg (GnuPG) 2.0.27 (Gpg4win 2.2.4), libgcrypt 1.6.3 (marked 2015). Though command line is not the principle method with Gpg4Win it seems a fairly basic function.