Suggestions when Running Smart App Control on Windows - keyboxd Being Blocked

I have been attempting to verify files today since installing the latest version of Gpg4win (4.2.0) but have come across an error when connecting to keyboxd.exe. Windows Smart App control is enabled for my machine, and I am reluctant to switch it off as doing so would require a fresh install of Windows in order to set it up again. I was wondering if there is a possible workaround to get going in the meantime?

GPG Error Log - CreateProcess(detached) failed_20072023.txt (807 Bytes)

you could disable the use of keybox, see instructions here:


Thank you for your feedback. I will try turning on Windows Smart App Control to see if I can reproduce your problem. From the top of my head I can imagine that keyboxd is not signed by us accidentally as it is new, but it should not be different from other background processes. Is there no way to add an exception for this process?

Ok, Windows Smart App Control cannot be turned on later. (And requires that you send additional data to Microsoft).

But my suspicion was correct. The problem is that we have accidentally not signed keyboxd.exe I have just changed that for future releases:

And since keyboxd is part of the gnupg package I also cannot just sign it and upload a new Gpg4win package. So for now please do as Bernhard suggested open a console window and use the:
gpg-disable-keyboxd command

  • Thanks

I was able to disable keyboxd using the method suggested here, but I had to first exclude the gnupg/ folder itself from MS Defender in order for this command to run without error. I’ve attached a screenshot to confirm the folder and location which worked for my machine, with everything seeming to be working fine for now.

Screenshot 2023-07-21 135622 - Excluding folder from MS Defender.png