Silent install using ini file problems

I try to install in a server where I will not use any GUI programs and call gpg2.exe from services. I use an .ini file (see below) for the installation. I experience two problems:

  1. The installer installs Kleopatra even though I set inst_kleopatra=false.
    Known bug? Workaround?

  2. If I specify --homedir c:\xxxx, I can’t generate keys as it can’t connect to the agent:
    gpg: can’t connect to the agent: IPC connect call failed
    gpg: problem med agenten: No agent running
    gpg: can’t connect to the agent: IPC connect call failed
    gpg: problem med agenten: No agent running
    gpg: Skapandet av nycklar avbröts.
    The key files are created in the specified folder, but the folder ‘private-keys-v1.d’ and the file ‘S.gpg-agent’ is created in c:\Users\xxxx\AppData\Roaming\gnupg.
    How can I force gpg2.exe to use a specific directory instead of the users’ AppData folder? I will call gpg2.exe from a service running under a service account, so using a specific folder would help a lot.

Any help is appreciated!
Thanks in advance,

Here’s my .ini file for silent install:
; Installation settings. Leave out or leave empty for default settings
inst_gpgol = false
inst_gpgex = false
inst_kleopatra = false
inst_gpa = false
inst_claws_mail = false
inst_compendium = false

; The locations at which linkages are to be prepared.
inst_start_menu = false
inst_desktop = false
inst_quick_launch_bar = false

; In contrast to the other options, this option overwrites
; the user’s settings in the installation assistant.
inst_start_menu_folder = Gpg4win

; Standard configuration files.
gpg.conf = c:\pulbrsintftpT\BTSConfig\GnuPG\config\gpg-site.conf
gpg-agent.conf = c:\pulbrsintftpT\BTSConfig\GnuPG\config\gpg-agent-site.conf
trustlist.txt = c:\pulbrsintftpT\BTSConfig\GnuPG\config\trustlist-site.txt
dirmngr.conf = c:\pulbrsintftpT\BTSConfig\GnuPG\config\dirmngr-site.conf
dirmngr_ldapserver.conf = c:\pulbrsintftpT\BTSConfig\GnuPG\config\dirmngr_ldapserver-site.conf
scdaemon.conf = c:\pulbrsintftpT\BTSConfig\GnuPG\config\scdaemon-site.txt
gpa.conf = c:\pulbrsintftpT\BTSConfig\GnuPG\config\gpa-site.conf

I only use gpg at the command line level on our server and had no need for Kleopatra so I installed the lite version. It still installed Kleopatra but it did not activate it. So it did not embed itself into Outlook or anything else. Worked great, only left a Kleopatra icon on the desktop.