Silent install issues - StartService: ec=1-56

Hi. I’m hoping to upgrade from GnuPG 1.4.x. I automatedly deploy software across organisations using WPKG.

When I run try to install GPG4Win 2.1.0 on Windows XP Pro SP3, silently, using ‘gpg4win-2.1.0.exe /S’ I get the error “StartService: ec=1-56”.
It installs fine when the installer is run manually.
I can’t find any mention of this on the web, can anyone help me understand this issue please?

Also the GPG4Win installer reboots when finished. When running silently it shouldn’t just reboot, as that can be handled by the automation software.
(Even using the GUI it reboots without prompting, where as the GPG4Win uninstaller at leasts asks if you want to reboot now or later). This is pretty poorly behaved in my opinion. Is there a way to prevent it rebooting?

If I fail to find a resolution to these issues, is there an equivalent GnuPG installer to gnupg-w32cli-1.4.11.exe, which has always worked flawlessly for my uses. I’ve looked around and can’t find one.

Pete Boyd