Signed messages are not displayed - Gpg4win 3.0.1 / OL 2010 / Win 7


I use latest Gpg4win 3.0.1 with OL 2010 on Win 7 (32-bit) and have the problem, that a signed message is not verified and displayed.

I recieve messages from and have imported the public key, but Outlook hangs and always tells me:

“OpenPGP Verschlüsselte Nachricht
Bitte warten Sie während die Nachricht entschlüsselt / geprüft wird…”

I was wondering, because after installing Gpg4win I sent a message to myself that I signed and encrypted before - that worked without problems!
So I tried sending a message to myself, that I only signed and OL 2010 hangs again. Gpg4win asks for the apropriate key/certificate, but does not ask for a password and hangs.

Any ideas? Thanks!


HI Ivan,
does the problem persist, if you restart and try again?

While hanging: Are you able to do similiar crypto operations on the command line?

Best Regards,

Good morning Bernhard,

yes, when restarting OL (after killing the OL process) the problem still persists. I tried serveral times and noticed more and more gpg.exe processes in my task manager and gpg-agent.exe startet twice.
After killing also the gpg.exe and gpg-agent.exe processes I did a “clean” start again - still the same: OL hangs.

Unfortunately I’m not familiar with the command line of gpg4win. Could you please give me a quick hint what commands to use?

I must admit that I noticed this behavior regarding signatures already some versions of gpg4win ago, but I was to lazy to post - I guess it’s a bug in combination with OL 2010.


Sadly I can’t reproduce the problem. I’ve tried with PGP No-Mime (inline) signed mails and PGP-MIME Signed mails with Outlook 2010 on Windows 7. Works for me :-/

Can you please send us a logfile:

  • Open Regedit and edit “HKEY_CURRENT_USER\Software\GNU\GpgOL”
  • Set enableDebug to 1922
  • Set the value of logFile to some writable path. E.g ( c:\users\foo\Desktop\gpgol.log )

Then start Outlook and open the CERT Mail.

Please note that every crypto mail you open while enableDebug is set to 1922 will be logged with the contents. So you might have to strip that log down. The relevant part (if the broken mail was the last mail you looked at) is the stuff following the last: “mail.cpp:pre_process_message: GetBaseMessage OK.”


Hi Andre,

I don’t know what happend:

I enabled the debug logging as you suggested and after a restart of Outlook everything worked fine!
Once again then everything hung checking the signature, but after killing all processes invoked by gpg in the taskmanger again, Outlook and gpg4win are working fine now. Great - thanks a lot!

What is the default value of enableDebug? I found it set to 1 before changing it to 1922. I did already some debugging some time ago…
I want to have it “safe” again :wink:



I’m having a similar same problem under Win10. See [T3538]. Log Files included.

Best regards, Tilo


well my error is appearing again :-/

Seems that it works only, when gpg.exe process is killed manually.
Some log still needed?

I noticed this issue also on the mailinglist now:


maybe this would work…

Found this workaround

"Until we have released a new version of gnupg or gpg4win, please use the workaround of adding

to the file “gpg-agent.conf” and restart gpg-agent (“gpgconf --kill all”)"


please try Gpg4win 3.0.2,
thanks again for your support in finding the defect.