Signature using md5 algorithm are rejected

Hi everyone! Is there anyone here encountered the error that i am encountering now?

Error message:

gpg: Note: signatures using the MD5 algorithm are rejected

gpg: : skipped: Unusable public key

gpg: : encryption failed: Unusable public key

Here is the command that i am using to encrypt:
gpg2.exe -r --encrypt

Thank you guys in advance!


in the last years GnuPG deprecated the MD5 algorithm as it is known to be insecure. That includes self signatures. E.g. The signature made by a key to bind a user ID to it so this also affects encryption to other keys.

You can change the behavior by either specifying the option to allow it (allow-weak-digest-algos) on the command line:

gpg2.exe --allow-weak-digest-algos -r --encrypt

Or by putting the line: allow-weak-digest-algos into the file %APPDATA%/gnupg/gpg.conf

But you should probably ask the recipient of your message to update his or hers key.

(See: )