Setting default recipient for encryption


I have tried searching the forum and could not find any information about this. I primarily use Kleopatra / GpgEx / gpg for encrypting files (for myself) before uploading them to cloud storage. As such, I usually don’t need to select any other recipients for the encryption than myself. After selecting “encrypt file” from the Kleopatra dialogue that pops up, I have to select my own key on the “For whom do you want to encrypt?” dialogue. Is there any way to auto-populate that window with my key? It would save me considerable frustration, given I use this option quite often.

I am running:
Kleopatra v2.2.0-git945878c
Gpg4win v2.2.4
Windows 8.1 x64

You can put an entry in the gpg.conf file. The skeleton file often supplied with gnupg shows some examples and I quote an extract below :

If you have more than 1 secret key in your keyring, you may want to

uncomment the following option and set your preferred keyid.

default-key 2222999988887777666655554444333322221111

If you do not pass a recipient to gpg, it will ask for one. Using

this option you can encrypt to a default key. Key validation will

not be done in this case. The second form uses the default key as

default recipient.

#default-recipient some-user-id

Use --encrypt-to to add the specified key as a recipient to all

messages. This is useful, for example, when sending mail through a

mail client that does not automatically encrypt mail to your key.

In the example, this option allows you to read your local copy of

encrypted mail that you’ve sent to others.

encrypt-to 22221111

I don’t know exactly where this will be in Windows8, but in Windows7, the conf file is typically in /Users/yourusername/AppData/Roaming/gnupg/

I expect you’ll find something similar in Win8.


Thanks for the help, Phillip.

I’ve set the following in my gpg.conf file, but unfortunately it does not seem to make a difference when using the GpgEx/Kleopatra GUI (obviously with XXXXXXXX replaced by my key’s ID):

default-key XXXXXXXX
encrypt-to XXXXXXXX

This does work for the CLI for gpg, as gpg -e no longer asks for a recipient list. It would appear that now the question is how to get Kleopatra to respect this configuration…