Setting default pgp key for signing...

Several different private keys for different usage are stored. First one in GPA list is used as defauklt key.

How to set a key a default key for signing?

In GPA backend settings ‘default-key’ is set.
gpg.conf and gpa.conf are showing under ‘default-key’ the correct one.

If right click signing in file manager, another key ist offered as default key!?

Win7prof-64, Gpg4Win-Light 2.2.1

I’m using Win7-64bit with Gpg4win 2.2.0 ( I haven’t yet got around to the upgrade.)

I set the default-key in Kleopatra and then GPA displays the same setting (not surprising). When I do a right click signing in file manager, it’s a Kleopatra dialogue box which is displayed and the correct default-key is offered as first choice. I do not find the problem you list.

I remember in a previous thread that you were having problems with Kleopatra and wanted to be able to select GPA for GpgEx file manager operations. Did you make any change in this area ?

Thanks for reply. Currently I do not have Kleopatra installed because of some issues, only light version 2.2.1 with GPA is installed on Win7prof-64b.

So setting the default key in Kleopatra isn’t possible for me…

Other thread: Sorry, I did not find any solution for switching between Kleopatra <=> GPA for usage with GpgEx. (Because of this I am using the GPG4Win-Light version, so GpgEx uses GPA…)

You can add a line to the GPG config file to tell it which key you want to be the default.

The default path is: C:\Users\Owner\AppData\Roaming\gnupg

Open this file with a text editor (such as Notepad). You will see the following text:

###++±-- GPGConf —+++###
auto-key-locate local
keyserver hkp://
###++±-- GPGConf —+++### 09/09/13 14:14:26 Eastern Daylight Time

GPGConf edited this configuration file.

It will disable options before this marked block, but it will

never change anything below these lines.

Right under that you can add this line:

default-key [your key ID]

Of course, you will want to replace [your key ID] with the actual ID of the key you want to use as the default. Save and close and that’s it!


It did work, thank you!