Select sender encryption key in Outlook


I’m using Outlook with Kleopatra and I have an issue when sending with a different sender/From name.
I can pick from different senders set up in Outlook, but gpg4win will always try to sign the message with my default private key, and I can’t find the location of the option to use if I need to chose another private key.

It will always use my personal private key even if I have a private key for my alternative sender configured.

Does anyone know where I should be looking for this option/feature?

Thanks !

GpgOL should detect when the sender is changed. Are you on the latest version? We did some improvements for shared folders to pick the right key in that case.

Does it show you the wrong sender identity where it reads “Sign this message as:” ? In the security approval dialog?

Alternatively you can disable the filter by clicking on the icon to the right of the key selection to choose an arbitrary key for signing.

Thank you -
I’m not using the latest version because of company restrictions, I’m using 3.1.11.
I’m not seeing the “security approval dialog”, it just asks for the passphrase for the default identity even if I had chosen a different sender.

But I have been able to make the prompt appear by checking the “Always show security approval dialog” box in the GpgOL settings.

That allows me to chose the signing identity, and solve my issue.

I’m not sure if this is the preferred way to achieve the result, but at least it works.

Thanks for your quick answer Andre !

No the preferred way is that GpgOL finds the matching key by itself. But I’m glad you found a workaround. The fix for the sender identity selection is in 3.1.12 :wink:

same problem here with 3.1.15. What can I do?
P.S. See also

You can enable that the security approval dialog is always shown
and select the other key to use manually.
This is just a workaround, of course.

The next step for a long term fix is to
open an issue report on