I installed gpg4win2.3.3 on Windows 7 and I use batch data:
Gpg --recipient xxxxxx --encrypt-files * .txt
Works on Windows 7 but does not work on Windows XP where it shows:
“Cant open, no such file or directory, failed encrypt”

Please answer if someone knows.
Thank you.

try gpg2 instead.

Does not work with gpg2.
Thanks for the advice.

It’s interesting to throw out * (star) from the bath file (gpg --recipient xxxxxx - encrypt work.txt) and I only insert one file (work.txt), and in that case it’s OK. That is, the bath file is encrypted (work.txt).

Is it possible that the thing is in another command or option in the bath file.

Is it possible that the problem is in the Charset option.
In Windows 7 the charset is ctf-8 and in Windows XP it may be another charset.
In windows XP in the bath file does not respond to character * threads?.

I installed version 2.0.0 and the bath file works on Windows 7 and Windows XP.

Hi there,

So, to summarize: You tried Gpg4win 2.3.3 and batch encryption with wildcarding (*) and it doesn’t work with XP, but works with Win 7. Under XP it stated, that the file doesn’t exist. As You elimented the Wildcard in worked with both, Win 7 and XP. Then you installed Version 2.0.0 of Gpg4win and the wildcarding in batch encryption worked with both, Win XP and Win 7.

With wich console did you try to encrypt? PowerShell or normal Windows Command Console?


I use a normal Windows command console
and software with command line and graphical interface

Dear Beni,

in the past we had problems with different runtime variants on windows,
so I remember that sometimes wildcards work and sometimes they don’t.

We’ve made an effort to fix them for Gpg4win 3.0.0, so please try the latest beta and let us know how good they fare.

Thanks a lot,