Running gpg2.exe ??

I recently installed Gpg4win 2.1.0. However I have not included GpgOl and Claws Mail in my installation. I am running Win7 32/64 bit.
GPA and Kleopatra works fine.
Now I want to revoke a couple of old signatures from my key, generated in 1997. I can see that I need to use CommandLines to do that.
Running gpg2.exe opens a window, but no matter what I type, nothing happens.
What goes wrong? Is something missing in my installation?
Hope someone can help, thanks.

It seems. I’ve got it to work.
So far, I just typed C:\Program Files (x86)\GNU\GnuPG\gpg2.exe,
and nothing happened.
Then I tried to enter a command line after the above mentioned command, and now it worked.
I got an answer and the command prompt: gpg>

But how do I get the command prompt on startup.


I found this website very helpful with gpg commands:

Also gpg2 -h will bring up the list of commands in the command window.

Many thanks for answering.
I have tested gpg2 -h.
Command window opens, and I can in a split second see text coming in the window, then the window shuts down immediately.
How can I avoid it?
If I for example, enter
gpg2 --edit-key ,
then the window remains open.
I am apparently ended up in a key editor.

Your command window should not be closing until you type in Exit. I can scroll back up and see everything that spit out after gpg2 -h. Also why do you want to stay in command mode for gpg. I just issue a sequence of commands so it runs gpg with -some command(s) and then back to the dos prompt but the command window stays open until I exit.

It now appears that I have found the solution.
When the command
c:\Program Files (x86)\GNU\GnuPG\gpg2 -h
is executed in the command window, then the window shuts down immediately.

I think it is because the command in the command window does not like spaces in the path name.

If, however, I only enter:
c:\gpg2 -h
in the command window, then it runs as it should.
Many thanks for your input.

if you need use a path or file name with spaces in it in the future use double quotes like “c:\Program Files (x86)\GNU\GnuPG\gpg2” -h