problem receiving encrypted attachments

Last week I installed PGP4WIn version 3.1.3 and it seemed to be working fine. Today, somebody tried to send me an encrypted attachment and for some unknown reason this did not arrive. The message itself arrived without error, but the attachment is gone. Since I don’t have the public key for the address the message came from, I first thought that might cause this problem. However, resending the attachment from an address I do have the public key for gave the same result.
Any idea what might cause this problem?
I’ve tried going back to version 3.1.2, but that hasn’t solved the problem.
Sending e-mails with encrypted attachments works fine.

Forgot to mention that I use OL2016 (don’t know if that is important in this case).

Maybe the attachment was removed in transfer by some security / spam filtering gateway as the attachment could not be inspected? If the mail itself is not encrypted but only has an encrypted Attachment GpgOL should not actually touch the mail.

You can try to disable GpgOL with
File → Add-ins → Manage: COM Add-ins → Go…

And there uncheck GpgOL. If you then restart Outlook and look at the Mail again, if the attachment is still not shown this means that GpgOL is not the problem.

Dear Andre,

The message itself was also encrypted. When I disabled GpgOL in OL2016, I only saw a blank message with two attachments: ‘PGP/MIME version identification’ and ‘OpenPGP encrypted message.asc’.
However, your suggestion gave me an idea: we still have a PC in the office on which OL2010 is installed in combination with GpgOL version 2.2.4. When I opened the message there, I saw that the attchment is indeed present.
But for some reason, I don’t see the attachment anymore when I open the same message in OL2016 in combination with version 3.1.2 or 3.1.3.
Additional info, don’t know if it will help narrow down the problem: Last week, after installing version 3.1.3, I received two encrypted messages with encrypted attachments from the same sender. Those were received without any problems and when I open them now, I can still see the attachments.

Hope you can help.

Best regards,

Then it might be a bug in GpgOL indeed. We had similar bugs in the past where attachments were not parsed properly from crypto mails but to our knowledge everyone of these is fixed. So it would be interesting to get more details of your situation.

Could you enable GpgOL debugging as described under:

And send the log to ? In your case it should be with log level 1 as it contains productive data.

That would help us to solve your problem for the next release.