Outlook problem - outgoing emails are empty

we installed the recent version of gpg4win and I assume we have no technical issues because I can decrypt incoming emails without problems. However, when I encrypt an outgoing email then the receiver only sees an empty email and two attached files with the extension .dat.

I assume that I need to chnage my settings and have already tried activating/deactivating s/mime and changing formatting to plain text.

Can anyone point me to what I need to configure?

Hello Robert,

assuming your are using Gpg4win 3.0.0…
which versions of Outlook and Windows are we talking about?
Your outgoing emails are transported by Exchange?

If you can decrypt and S/MIME was off, you are using OpenPGP.
(I’m assuming this from now on.) So S/MIME should kept switched off.

By default GpgOL sends out OpenPGP/MIME emails, because this is
the standard for sending out encrypted emails.
Some receipients have email clients that do not support OpenPGP/MIME
or MIME at all, so you can try send emails to those people by activating
the “deprecated no-mime” (inline) option in GpgOL and see if this is better.

Best Regards,

Hi Bernhard,
we are using Office 2010, 32 bit. OS is Windows 7, mails are sent via Exchange.

Thanks for the advice, as we are using the German UI I will attach a screenshot, is this the setting you meant?

Regrettably I do not know which email clients our customers are using, and I have no influence on them.



Hi Robert,

yes this is the setting which switches between
OpenPGP/MIME and deprecated no-MIME.

With a MIME-compliant client, things should be fine on the other end.
As MIME is pretty standard for more than two decades. :slight_smile:
(A workaround for some people is to save the encrypted attachment
as file and use a file based approach for decrypting it. A better solution would be if more people would get clients that support OpenPGP/MIME.)

You could send email to yourself to see if it works as it should.

Best Regards,

Hi Bernhard,
the changes helped a bit. When using plain text format and the setting you recommended, the receiver still sees an empty email with attachment. However, he can decrypt the file and see my text (with a bit of coding fragments for certain characters).

If this is the best we can get it won’t be great, but sufficient.

Strangely they use Outlook 2010 too as I could find out, but with a different PGP plugin.

Best regards,

Hi Robert,

good to know that you found a way that is at least okay to work with!

Do you know which other Outlook-Plugin is used by your communication partner?
(It would be interesting to know compatibility problems. We do tests with
other implementations, but there are so many out there. )