No Secret Key

Hi I had issues while decrypting my 2fa messages so I created a new key and I am still getting the same error

The GPGME library returned an unexpected
error at gpafiledecryptop.c:538. The error was:

No secret key

This is either an installation problem or a bug in GPA.
GPA will now try to recover from this error.

Details of the error:
[GPA 0.10.0, GPGME 1.17.2-beta65, GnuPG 2.4.0]
gpg: encrypted with RSA key, ID 37C3F700F99522CD
gpg: public key decryption failed: No secret key
gpg: decryption failed: No secret key

Please help to fix this!


did you yourself encrypt these messages? Then you have to use the same key for decryption as you did for the encryption. If you deleted or lost the private key that you used for encryption than there is no chance to decrypt the files.

With regards,

No When I try to decrypt my 2fa msg then this error occurs I have changed it with the new PGP key.

I dont know why even changing everything it gives me the same error

What do you mean by “changed”? Did you change the key? Then it is clear that the decryption does not work.

If a file was encrypted by key A then it has to be decrypted with the same key A. If you create a new key B you cannot decrypt files with it which were encrypted with key A.

When you get the error “No secret key” that means that you still have to import the correct key.