Multi-Language issue

Hi, I’ve encountered a very strange bug when using Kleopatra.

I primarily speak English, but have been learning Japanese so have set my Windows 10 date/time region to display dates and times in Japanese. This seems to have confused Kleopatra immensely, as the settings screen and a number of common buttons like “OK” and “Cancel” have all switched to ja.

I have checked that I’m on the latest version, and manually set my language to English in the Kleopatra settings, but that is not fixing most things. Is there something else I can do to fix this?

Hi @Ryltarr,
thanks for trying Kleopatra in Japanese. :slight_smile:

First: You did a complete restart after configuring the Kleopatra language? If so, it possibly is the case the crypto backend still writes the strings out in Japanese to frontend applications like pinentry, which will just display them. So you could set environment variables so that a call of gpg --version in the command line bring out something in English. (At least I hope so, I would need to check which environment variables work here.)