Lookup on Server - not returning any data

I am trying Lookup on Server for signing.authority@iohk.io. Nothing is returned. I am not sure how to troubleshoot this. I am running on Win10. I have also tried turning off the firewalls to make sure nothing was blocked. Any help is appreciated–I am new to this tool.

Hi John,

welcome to Gpg4win (and its crypto engine GnuPG)!

If you are looking for a public key that is associated to an email address, there are several methods. And you can only find one, if one exists and was published.

Am I assuming correctly that you know that a public key for this email address exists?

The first method today should be to ask via WKD (if a web key directory entry exists) for iohk.io.
In general Gpg4iwn calls its crypto engine to do the work, so if you want to do more (and your a a bit technically inclined), you can use command line operations and raise their verbosity to get a lot of information for technical diagnosis.

E.g. I’ve tried
gpg --locate-external-key signing.authority@iohk.io
gpg: error retrieving ‘signing.authority@iohk.io’ via WKD: No data
gpg: error reading key: No data

Okay, no WKD entry.

Next would be public keyserver, you can do this manually, e.g. by going to
http://keys.gnupg.net/ (note this is round robin DNS, so it will direct you to different servers,
which some may not be working at the time so the experience will vary.)
Got me pubkeys.

gpg --keyserver keys.gnupg.net --search signing.authority@iohk.io
gpg: data source: http://hkps.pool.sks-keyservers.net:11371
gets me pubkey sometimes. So it seems that some public keyserver work,
and have the pubkeys, others doesn’t.

(There are more ways to debug this.)

To exclude your firewalls, try to search for other public keys that are more likely to be carried by many public keyservers. If you find some, then it is not your network connection, but
the keyserver you were randomly connected to.

Does this help?

Best Regards,