Loading Certificate Cache

I’ve noticed quite often when I start Kleopatra there is a long delay while it says “Loading Certificate Cache”. Sometimes a minute or more. I could understand if I had lots of keys that could possibly happen but I have only about 18 keys in there.

Any ideas how to resolve this?



Hi Mark,
the long delay maybe caused by a network delay when trying to check the revocation information of the certifications (if you have CMS certificates for S/MIME?)
If it is a long network operation, even one pubkey in your repository could cause it.

There are other potential reasons of course.


Hi Bernhard,

I only have PGP keys in there, no S/Mime so I can rule that out. This morning when opening Kleopatra it took almost 2 minutes for that Loading to Complete. Is there a way to narrow down the culprit? I only have 18 keys in there and if one of them is causing the problem I will delete it I did look and I have 2 keys in there that have expired, could that be the cause? Is it looking for updated keys or ??


Hi Mark,

there is no obvious cause I could think of.

To analyse this further I’d think of:

  • trying to turn up diagnostic messages (see documentation)
  • you could do a backup of all your keys and then narrow it down by trying half of the remaining set (and then doing it again) to see if one key is causing problems.
  • some settings could cause network traffic, maybe there is something to monitor (on GNU/Linux systems this would be Wireshark, but I don’t know what a good approach is on Windows). You could see if and AV or firewall products have an influcence.