Kleopatra will not open

I’ve tried the 2.1.1 beta version & the 2.1.0 stable version & have uninstalled & restarted multiple times & Kleopatra just will not open.

GPG & Clawsmail open like normal.

What could the issue be? I need Kleopatra to create & verify certificates correct?

What are your language settings? I suspect this bug: http://wald.intevation.org/tracker/index.php?func=detail&aid=1099&group_id=11&atid=126

That sounds like my issue, I am using English (I think) where/how can I double check the language settings for GPG4win?

These are language settings for non unicode programs, in windows xp. Control panel\regional and language options\advanced\Language for non-Unicode programs.
If language selected there is not english or german, kleopatra fails to launch.

I’m running Win 7 64

Inside of control panel>Retion & Language>Format is English (United States)

So it seems the language is set correctly, there is nothing inside of GPG I need to change?

What other reason could there be fore Kleopatra not start?

I do not have any windows7 installations availeble, to check, but in windows vista setting for non unicode programs is at: regional and language options\Administrative\Language for non unicode programs (there is a button to change hat setting, it seems to invoke UAC). In windows xp and vista, it is the last tab in dialog.

Ok checking under Administrative inside of Region & Language I see that the Language for non-unicode programs is also set to: English (United States)

Next option to check?

As mentioned I’m running the stable version of GPG 2.1.0

Then this issue is caused by something else. BTW, just tested gpgwin installation on vista64 and kleopatra launched even when language setting were not english. (on winxp32 it never worked). This was unexpected.

Anyway, i discovered this issue in spring, last year, thread in gpg mailinglist archives: http://lists.wald.intevation.org/pipermail/gpg4win-users-en/2011-April/000598.html

There were used debugview (debugging tool) to find out what was failing. Back the googling for errors found, yielded that language settings bug, and changing language settings, proved that it is the case. Your case seems to be different. Link to debugview still works (in that archive message).

Hmm yes that doesn’t seem to help my situation any.

Can you or anyone else think of any other options to get this working?

I’m new to PGP/GPG & really wanted to get into it with the GPG4win program but obviously want the entire program, including Kleopatra to work properly.

Debugview did not show anything?

I just downloaded the program now & trying to figure it out, I have no idea how to use it.

Can you give me some quick help on how to scan for the proper files?

On my system (vista64), when simply launched, debugview shows only gpg related debugging output. If you do not have any gpg related programs running, probably just start debugview, and then attempt to start kleopatra.

Ok I had debugview open & tried to open Kleopatra & received this error message in debugview:

[48552] Debug:Statup timing: 3 ms elapsed: Command line args created
[48552] Critical:kleopatra(48552): KUniqueApplication: Cannot find the D-Bus session server

Does that help you?

Google did not find anything useful. I have no idea, what to do next.
You could try gpg mailing list.


This is no solution to your problems - but as I too
have had way too many problems with Kleopatra
I have uninstalled it.
I only use gpg4win as an installer of the newest
GnuPG-version and use GPGshell as key-manager,
encryption-tool etc.
I never had any problems ever since!

Btw.: I am using Win7 x64.


Bernd Leutenecker

I’m new to the whole PGP/GPG thing so bear with me.

I thought I needed Kleopatra to make & verify certificates? (Which I really don’t quite understand yet)

So you’re saying GPGshell is the same as Kleopatra?

What if I try to uninstall & reinstall it with a different download? Will Kleopatra ever work?

There are many ways of making and verifying certs (pgp keys). Using a GUI application (such as kleopatra (included in gpg4win), GPA (included in gpg4win) or gpgshell) usually is the easiest way. Keys can be generated also by command line gpg tool. Some applications using gpg also provides GUI means of generating and managing keys (such as enigmail extension for thunderbird mail client). Kleopatra is required to use GpgEX shell extension, which allows to encrypt/decrypt/sign/verify files in windows explorer. That shell extension is available (was, when i last checked) only in 32 bit version, so it probably will not work in 64 bit windows explorer.

So you’re saying that the GPA program does the same thing as Kleopatra when it comes to maintaining & verifying certificates?

Are certificates & public/private keys the same thing? I’m just a little confused.

I understand that “public key” is given out freely so others can send me encrypted messages & that I keep my “private key” in order to decrypt them.

But what is/where does a “certificate” come into play?

I’ve created my public & private key set, is there a dummy program I can use to practice sending/encrypting/decrypting messages so I know I’m doing it correctly & comfortable with it?

Also I’ve hidden my public/private key in a file, do I ever need to select this file while using GPA or does it always remember it for me when encrypting/decrypting stuff?

Thanks for the help btw.

I do not have GPA available right now, but it provided a list of available keys, it was possible to generate keys and sign other users keys. (maybe something more, cannot remember).

Certificate is a public key + information about key owner (name and email) + some signature over previous 2 parts. pgp certificates historically are called keys. (certificates contains public keys).

GPG maintains a list of available public an private keys (keyring), all applications using gpg accesses this list through gpg.

GPG by itself can encrypt/decrypt files. If that is enough for testing, then command line gpg could do it. Maybe kleopatra, too, could do it (have not tested), gpgshell also could do it. If you meant emails (sending/receiving; encrypting/decrypting), then there will be necessary an email program supporting gpg. There is included claws mail. There is available enigmail plugin for thunderbird. Also, it could be possible to use anything, by just encrypting files and sending them as ordinary attachment. (and handling them as ordinary files when decrypting later).
To get standard gpg encrypted email, you will need a gpg supporting email program. For testing there were a bot, but i have not tried it. And did not found a references in gpupg.org website. You could also sent to yourself.

When generating keys, gpg adds them to default keyring file. To get these keys to a separate file, you must explicitly export them. GUI applications, when generating keys, just controls gpg and generated keys ends up in the same place as when generated by gpg command line tool. Commands for exporting public and private keys are separate. To use a key from external file, that file either has to be set up as default keyring, or that file has to be imported into default keyring.

I too have found that Kleopatra doesn’t open for me. Faced with this dilemma, I found a way for GPA to encrypt/decrypt messages. In GPA there is a button for “Importing” Keys from files. Once they have been imported, they can be identified by the name applied. Open the “Clipboard” in GPA. In the “Clipboard” there are both buttons for “Encrypt” and “Decrypt.” If you’re encrypting, type your message in the clipboard and apply “Encrypt” and apply the appropriate public key. If decrypting, paste the message in the “Clipboard” and apply the appropriate private key.
I hope this helps!