Kleopatra missing dlls

Following the beginner guide, installed everything, started Kleopatra, immediate failure for missing libkdeui.dll and libkleo.dll. Can find nothing to help, anywhere.

Do I give up now or if not, where are these dll files? The installation does not include them. Very irritated at the waste of time so far.

Windows 8, 64bit.

These two files were in my C:\Program Files\GNU\GnuPG folder. Not sure why your install didn’t include them. If you know how to install and register dll files, I can give you a link to a zipped file containing the two.


Thanks! I found them in the equivalent folder in Program Files (x86), they were there all the time. However and mysteriously, Windows does not “see” them at all - they do not appear in Windows search results and I cannot run the application that requires them because it can’t see them either.

I tried running regsrv32 and it also could not find the files.

I then copied the files to Windows, to System32 and to SysWOW64 directories and ran regsrv32 on the lot.

In all cases I just got the ‘modules not found’ message.

I give up. I assume this is some Windows 8 problem - maybe unique to 64 bit, maybe not - that has no solution unless anyone knows differently.

Thanks for trying to help.

Windows 8 64-bit here as well. I’m getting similar dll errors.

kbuildsycoca4.exe System Error
The program can’t start because libkdeui.dll is missing from your computer. Try reinstalling the program to fix this problem.

kleopatra.exe - System Error
The program can’t start because libkleo.dll is missing from your computer. Try reinstalling the program to fix this problem.

These DLLs are located in my C:\Program Files (x86)\GNU\GnuPG folder. I’ve tried uninstalling and re-installing several times to no avail.

I run Kleopatra on a Windows 7 64-bit machine and the only difference compared to my 32-bit laptop is the lack of right-click options. So I would guess the problem is with Windows 8. I don’t have Win 8, so I can’t test this theory.

Until a fix is found, you might try using the command line interface. It’s a bit more complicated, but not by much. And, unlike using Kleopatra, the command line will allow you to generate 4096-bit keys.

More info on command line syntax can be found here:

Just thought of this, as well:

Have you tried running Kleopatra in “Compatibility Mode”. I’m not even sure Windows 8 has this option, but if so, it’s worth a try.

Good thought! And it works, though Windows will tell you that it didn’t. Go figure. Use compatibility mode for XP service pack 3, and ignore the message from Windows stating that it’s an incompatible application. It’s not.

Having said that, after all the hassle I installed Thunderbird and using IMAP to handle Gmail, and the Enigmail OpenPGP plugin, it looks like I can continue to use web-based mail plus encryption using the one application. Unless someone knows differently …

That did the trick for enabling the GpgOL Outlook plugin for me. I just ran
C:\Program Files (x86)\GNU\GnuPG\kbuildsycoca4.exe and
C:\Program Files (x86)\GNU\GnuPG\kleopatra.exe
through the compatibility wizard in Windows 8. It offers to remember the compatibility settings for these files in the future as well. That way I was finally able to get GpgOL to run and function.

Thank you!

Awesome! Glad to hear it worked out for both of you. :slight_smile:

Also, if you haven’t heard yet, the new release of Gpg4Win is now available. Many fixes and updates were implemented, including those right-click options for 64-bit systems. It’s really worth upgrading.


Version 2.2.0 released on August 20, was the first version of Gpg4Win that worked with Outlook 2010 & 2013, and had support for Windows 8, so I am referring to that version.

I am using Windows 8.1 Update 1 and having reinstalled GPG4Win several times, am still getting this error. Considering that this error was first reported in August 2013, why has this NOT been resolved (8 months later)?

8 Months and this issue has not been resolved? and you get all that money from what? Donations? Well, you must like doing this for little or nothing so I expect better updates, fixes and enhancements than commercial software! Get on it already!

I don’t believe anyone is actually listening here. As you say, EIGHT months (and counting), and nothing is happening - not even a comment from a developer to say they have heard and are researching the issue.

Hi Chris, Hi All,

we from the Gpg4win Intiative do read a lot, but cannot react to everything.
From the thread it seems that the issue at hand was solved using the compatiblity mode (with the old version of gpg4win). Your report from April is the first mention
of the problem since 2.2.1 was published in October.

Next step would to be find out why this works on some machines and not on others
and then create an entry in the issue tracker that makes the problem reproducable
for developers.

Best Regards,


the reason we can not say that this is fixed is that as Bernhard wrote we do not know how to reproduce this. We have Windows 8.1 systems for testing and it works fine there.

The problem is that Windows is such a heterogeneous environment that we sometimes see issues that we can not reproduce. (I remember a kleopatra startup crash that only occured if you had Microsoft Office IME for japaneese installed o.O)

But there was a problem with Kleopatra DLL loading in some environments( >= XP SP2 ) that we were able to fix ( http://lists.wald.intevation.org/pipermail/gpg4win-users-en/2013-October/000851.html ). It would be interesting if this also fixes the problems mentioned in this thread.

Yes it is sad that the message is from last october and we still had no release that included this fix.

I am using Windows 8.1 Update 1 (64bit). Kleopatra did work on Windows 8 and also on Windows 8.1, but as soon as I upgraded to Update 1, it refused to load reporting the missing dll.

Can I suggest that you try the same update path as I used (Windows 8 → Windows 8.1 → Windows 8.1 Update 1, and you will find the same issue?

As reported already, I have uninstalled the whole package and re-installed several times with the same results.

Does this problem still exist with 2.2.2-beta ?

I’ve added a fix for some dll load problems there.

I resolved the problem by changing “Start In” path in kleopatra shortcut properties to >"C:\Program Files (x86)\GNU\GnuPG".

from kde bug tracking system…