Kleopatra Issues

I have a public key in my key ring that had different expiration dates depending on where you look at it. In the built in Open PGP key manager in Thunderbird it says it expires in 2022 but in Kleopatra it says 2027. Also in Kleopatra it shows “E_error” for the strength. I assume that is a bug??

That strength is not shown is indeed strange. As for the difference in the expiration date I assume that the key has subkeys with different expiration dates and that might be the reason.

Can you provide the output of “gpg -k userid_or_fingerprint” where you replace userid_or_fingerprint with the user id or the fingerprint of this key please. Or better yet attach the key here. Its a public key so it should not be confidential.

I think it might have been a fluke in the key server as I tried again and it seems OK so ??

It is possible that some data was stale within the different software components.
Also some keyservers do not work all the time or do not ahere to common standards,
so yet, it is possible that if you did keyserver operations, that different subkeys or signatures reached your GnuPG store.

As Andre already wrote: Using more diagnostics with commands on the command line, is the way someone would further investigate.


Is there any way to get around the message saying “Kleopatra cannot be run as administrator without breaking file permissions in the GnuPG data folder” ?

Thank you.

2021-01-12 23_30_49-Running as Administrator.png

See https://wiki.gnupg.org/Gpg4win/RunAsUser in section references.
(Please keep discussion topics focused on one question.)


Has this problem been solved? I have the same problem. Can you tell me how to solve it

Hi Yong,
did you read https://wiki.gnupg.org/Gpg4win/RunAsUser already?

Best Regards,