Kleopatra GUI no longer launches


Kleopatra GUI no longer launches. I have been runing version gpg4win-3.0.2 on a Windows 7 Ultimate Service Pack 1 machine for a couple of years without any issues.

So, I riedd installing the latest version 3.1.1 and it is the same issue.

Double clicking Kleopatra icon on my desktop - I can see the Kleopatra icon in the icons window - CTRL+ALT+Delete shows the kleopatra.exe *32 process, but it is inactive.

Any idea how I can resolve this? There are no error messages.


Hi Si,
please try starting Kleopatra on the command line, sometimes this shows more.



You can try to move %APPDATA%\kleopatra (usually c:\users\yourname\appdata\roaming\kleopatra )

Out of the way and try again. Maybe this helps as kleo uses this folder to store data about its UI state.

Hi Bernhard,
How do I do that?


I searched for what you said but could not find either.

Hi Si,

start a command line (cmd.exe) where you can type commands.

Go to the kleopatra icon, open its properties and use the path there, select and copy it, and paste it into the command line and press return.
(This will end on kleopatra.exe, you can also search for kleopatra.exe on the disk and use the path to there.)

Best Regards,

Hi Bernhard,

Kleopatra does not print its debug output to the console on Windows. On Windows the Qt Framework uses “OutputDebugString” for debug output. This can be viewed for example using debugview https://docs.microsoft.com/en-us/sysinternals/downloads/debugview

Best Regards,

Hi Andre,
thanks for pointing it out again.
There was something that I did see at some point, I believe in case of a crash,
so it is worth a try.


I did this, see attached screenshot.

What I do not understand is, I was using the older Kleopatra version perfectly, then one day it stopped showing its GUI screen, it just had the icon in the lower right handside taskbar.

Pressing Ctrl Alt Delete shows kelopatra.exe _32 stuck on 0% CPU power, the application doesn’t launch.

Clean installs makes no difference.

Please help, as this was the best software out there!

I rund Windows 7 Ultmate Service Pack 1.


Hi Si,
can you cd into the directory? And try to start kleopatra.exe there?

You may also need to install the debugview applicaton from Microsoft that
Andre linked. This will get us more info.

We are interested in understanding the defect and sooner or later, we will
understand it.

BTW: Does calling “gpg.exe --version” on the command line work?


Hi Bernhard,

I eventually got Kleopatra to launch using the DOS method as you said (see attached image).

Yes calling gpg.exe --version does work.

After getting it to work through DOS. I closed Kleopatra down, then tried launching it normally through the Windows Start - program Icon and it started successfully?!

At least now it works! I wonder if will continue to work or if I will have to do the DOS method each time?

Thanks for your help!



Hi Si,
it is good that it is working for you now.

And I don’t know why it stopped working and how the command line operations could have changed this. Wild guessing could be some sort of permission issue. Maybe executing kleopatra once wrote a file with different permissions or so. Again, this is just wild guessing, it is quite hard to know what windows is doing something from just a written permission. :wink:

However let us know, if you learn more details.

Best Regards,