Kleopatra (gpg4win 2.3.0) will not start in Windows 10 Home

Kleopatra will not start, no error messages, nothing. GPA works OK, but I prefer using Kleopatra.

My main development setup is Windows 10 now. I can’t reproduce your problem. Please note that if you pin Kleopatra to the Launch bar in windows it won’t work to launch from that.

Just today I’ve made a change in gpg4win to fix this problem but it will take some time until this gets released.

have you tried starting Kleopatra from the command line?
(e.g. see http://wiki.gnupg.org/TroubleShooting)
Seen any messages?


I tried this and got some missing dll notifications:


I checked and these are all contained in the
“C:\Program Files (x86)\GNU\GnuPG”


There is a kleopatra.exe in both the GnuPG directory, as well as one in the GnuPG\bin directory. The one in the GnuPG directory is considerably smaller in size, and no special icon.

I moved the one in GnuGPG directory to a temporary folder, and copied the one out of GnuGPG\bin to the GnuGPG directory. I tried starting it again using the command line.

c:>“C:\Program Files (x86)\GNU\GnuPG\kleopatra.exe”

No error warnings about missing dll’s appeared, however, I got this new message in the command prompt window:

c:>please add the path to dbus-daemon.exe to your PATH environment variable or start the daemon manually

Hopefully this helps with the troubleshooting.


does “path” show you a path to the gnupg directory?


No. Path only contains:

C:\Program Files (x86)\GNU\GnuPG\pub

I guess the next step would be to check with DependencyWalker or DebugView,
see links from http://wiki.gnupg.org/TroubleShooting

the small binary in \gpg4win\kleopatra.exe is a wrapper that is needed so that the dependencies can be found correctly.

You need that. Please move it back from your temporary location and back in the \gpg4win folder. (or reinstall) It needs to have the exact name kleopatra.exe this is the application you need to start. It will in turn start the larger process in gpg4win\bin\kleopatra.exe

Btw. we are aware that this is weird and Problematic (as it breaks pinning kleopatra to the task bar for example) and this will be fixed with the next major update of kleopatra I’m currently working on.

I have another idea:
Did you, by change install gpg4win with Administration rights. Started it and
now run it with user rights?
(Some other user reported issues with this https://bugs.gnupg.org/gnupg/issue1801 )


This worked!

I uninstalled gpg4win, rebooted (required to finish uninstall), then re-installed with Administrator privilege. I ran Kleopatra from the start menu and it worked like expected.

Thanks for the suggestion!