Kleopatra frozen (hangs for 2 hours) 3.0.2

From: Kenneth Benson

I recently installed gpg4win 3.0.2 and have been having problems with Kleopatra
ever since. When I run Kleopatra I get a self-test popup with everything passing
except dirmngr. At this point Kleopatra is frozen, not accepting any clicks(even
on the close box) and requires ending process from Taskman. I have tried opening
an elevated cmd shell and running gpgconf to fix dirmngr, however it simply sits
and does nothing(this was left running for 2 hours to be sure). I run Kleopatra
as administrator and it acts the same. I have un-installed and re-installed
without fixing this. Can anyone tell me what else I can check or try to get this
Thanks to all for any help you can give!
Because we had an issue with the forum software, I resend this post.
The issue is meanwhile solved.

Hi Kenneth,

there is a small chance that Kleopatra from 3.0.3 is better, so I could not hurt trying it.

But I guess your problem maybe caused by a hanging network connection.
If dirmngr on a fresh installation on the command line does not go out and fetches pubkeys, there may be a problem. Do you have any firewall settings that may cause dirmngr network requests to be blocked? (dirmngr will by default try ldap and http(s) for locating
certs, pubkeys and cert revocation lists, depending on what is used.)

Best Regards,