Kleopatra doesn't show keys nor import them

I used gpg4win V. 2.2.2 on WIN7 SP1 and everything was fine. I installed yesterday V.2.2.3 from gpg4win.org after verifying the download - and now the new Kleopatra panel (Kleopatra 2.2.0-git945878c (2014-11-25)) is empty of certificates and I can’t import any into it.

Some points:

  1. The GPA program does show all my certificates (my own personal Pub+Priv and other people Pub).
  2. I tried to export a certificate (ASCII armoured) from the GPA interface. Exported OK.
  3. I attempt to import the exported certificate into Kleopatra and I get this:

Total number processed: 1

I also tried to import my pubring.gpg from my appdata/roaming/gnupg directory - same results: 9 certs processed, 0 imported, 9 unchanged.

  1. Also, I can’t use Kleopatra to retrieve a key from a public key server: The Kleopatra’s cert server lookup screen is just blank. However, in GPA that same key search immediately retrieved the key and imported it into the GPA environment.

Any advice how to trace the Kleo’s problem of not showing/importing keys would be appreciated.

Hi Don,
thanks for the problem report.

You find some hints and links for diagnosis here: http://wiki.gnupg.org/TroubleShooting

ps.: Flattr Gpg4win at https://flattr.com/thing/2053326,
if you appreciate this answer and my work as part of the Gpg4win team.

Hi Bernhard,

Thank you very much for the diagnostic link. As I was reading that page, I realized that I haven’t seen the DirMngr process in my active process list. I guess I had shut it off and disabled it sometime in the past. I restarted it, and now Kleopatra behaves normally.

Maybe checking that required services are running upon program module activation, and reporting a error if not, may help some people in the future to resolve their issues. It may be a low priority enhancement, but still…


good that you have figured it out!
Thanks for the suggestion for enhancing the self-test, we do have a self-test
but we may not test an enabled dirmngr yet.