Kleopatra crashes on ok + interface issues

Gpgex/Kleopatra crashes regularly after a verification has run, when clicking on OK. I’m guessing the interface is ready while the backend is not?

I think I have seen this bug mentioned somewhere before on the bug list or mail list, but can not find it back, so perhaps it is fixed?

And I too have seen the three OK buttons. Also, some part of the interface has been localized to my region format (for currencies and time) even while running an English version of Windows (and of GPG).
Do I need to report that to your bug-tracker, to the KDE one, to the mailing list or can I leave it here?

GPG_Kleopatra Language Bug_Win7x64_ConfigMenu.PNG

The crash has been reported https://dev.gnupg.org/T3761 and is fixed but the fix is not yet released in a Gpg4win installer.

For the three OK Buttons, I still can’t reproduce this, I have to try again.

For languages → You can switch them in Kleopatra under “Help” there you can switch back to English language.

Time format is more difficult, Kleopatra uses the Systems values for that (which I think is the correct behaviour) and it is not changeable within Kleopatra.

Thanks for your reply. I’ll wait for that fix then.
And the 3-ok-buttons do not appear every time, i’ll try to capture them if I see it again.

As for the language, you misunderstand. As you can see in the attached image from that message and this one, the GUI in general adheres to the system language (English) just fine.
It are just a few menu’s that do not use the system language nor the set language, but localize to the format & region system variable. (Which I can not set to English, because then I would get Dollars or Pounds in all my other programs)

It is probably related to this bug, where I have something similar happening in Digikam. (And there sort of confirmed for Linux)

GPG_Kleopatra Language Bug_Win7x64_Marked.PNG

To followup here. The crash and the “multiple OK” buttons have both been fixed. For 3.1.

You can find the beta here:

As for the languages. Yes that is a problem. The buttons come from our GUI library, which only uses the Systems language (or here the format & region), while the other stuff comes from us and uses the language settings.

A fix would be imo that we ensure that the “set language” is used consistently. I’ve opened a Task for that; https://dev.gnupg.org/T3840