Internal error in GpgOL

Using outlook in office 2016, pressing the encrypt button appears attached error. I am using Windows 10 Pro and since the installation of the gpg4win package this function has not worked. I can decrypt messages from senders but the encryption function does not work. On other computers in our department with the same configuration and the same version of the gpg4win package everything works fine. Do you have any ideas what could be the reason? I have tried different versions of gpg4win from version 2.3.0 to the newest, except that with the new version no action appears after pressing the sign & crypt button.
I also attach a log file.


And log file

gpgol.log (15.5 KB)

Thanks for reporting this. Indeed we run here in an unexpected error using the Outlook Object Model. GpgOL is unable to figure out who is trying to send the mail.

From Outlook we get an:
“desc: We cannot complete this operation because we cannot contact the server right now. Please try again later.”

Which is unexpected. I would not have thought that finding out who the CurrentUser is would require a Server connection. Is this system offline and how are you connecting to exchange? Is it standard “Connected to Microsoft Exchange” or does it say something else?
Can you think of something special how this client is connected to the Server?

Btw. for your logs, please attach logs from Gpg4win-3.1.11 otherwise it is harder for us to understand the problem. As a result of your report I would at least like to improve the error handling in GpgOL for this previously unseen error. (With Outlook you never know :wink: )

Thanks for your help,

Thanks for quick answer. You are right, the user did not inform me earlier that he has an old unused MS Exchange inbox on a common profile with the main account, which is no longer used and hence the problem and lack of connection to the server.


I don’t see why this should be a problem. I mean yes the old Version from Ggp4win 2.x might have some issues with that because it might have had a problem with multiple accounts. But the new version should have no problems with an old unused account.

Can you please provide me with a log of a decently recent Gpg4win version 3.1.11 would be best with log level +trace.

Click on “Secure” and then try to send the mail. That will probably contain enough information for me to handle this better.