Import Certificate via Clipboard

I tried to import a certificate from a website by copying it to the clipboard and then using the import from clipboard. It said that there were no keys in the clipboard but I checked by pasting it to a blank text file in Notepad and it was there.

Is it broken or am I doing something wrong?

Hi Mark,
to verify that there is a pubkey/certificate in the encoded text,
you could save it in a file (via notepad or a different text editor) and import it on the command line with either “gpg --import” or “gpgsm --import”. There is a small chance that the encoded text you are seeing is not a certificate, or that the formatting is somehow broken.


Hi Bernhard,

I tried it again and it did work (well kinda as I later found out that key was expired) but it did import it. Just for a test, I also tried it on an OLD (lost) key of mine. It tried to import and then skipped due to it being PGP-2.

So it looks like it is working fine, not sure why it didn’t do it that other time. Probably as you mention some sort of encoded text that was not visible.


We have an issue in the currently released Kleopatra that it allows to paste in Text with Markup. So if you paste from a Word Document or something like that it might not work because some hidden Markup is included.

This is fixed now:

Probably time for a new release :wink: Working on it,…

Great! I will keep an eye out for the release.