How to get GPA or Kleopatra to work thru a proxy?

I have an HTTP proxy at work. Everything must go through port 8080 of I cannot get any of the keyserver checks in GPA or Kleopatra to work.

It looks like there is an http-proxy option, but it is greyed out in the GPA and Kleopatra preferences. If I try to manually add this to my gpg.conf file I lose all my keys from the keyring.

Sorry for the bump, but I’d be interested to know if there are any work-arounds for this.

The MIT PGP keyserver finally has a SSL certificate, so I wanted to revisit this. The gpg4win compendum explanation doesn’t work for me as my proxy forces all traffic to port 8080.