GPG4Win3.1.5-1: no connection to key server?!

I tried to receive key E21E2C3E from a key server, but GPG4Win3.1.5-1 responds with “2019-01-28 18:38:00 gpg[4304] DBG: chan_0x0000011c ← ERR 219 Server zeigt einen unbestimmten Fehler an ” (source not given), see attached log. It appears to me that it does not even connect to any server. Tested with other keys, same result.
With gpg4win-2.2.5 that was no problem. Do I need to specify some source? Which, where, why?

gpg.log (2.09 KB)

With gpg4win-3 we switched to the HTTPS keyserver pool by default. So that all communication is encrypted. You might want to open Kleopatra’s settings and configure another keyserver like “hkp://”.
Our default keyservers are under heavy load and abused.

We are currently working on it. The HTTPS keyservers are abused e.g. for file storage and they have other limitations and problems. It’s difficult to find workarounds and solutions. e.g. next weekend we developers will meet at FOSDEM in Bruxelles this will definitely be a topic there. But we really want a decentralized solution.

We designed the Web Key Directory as a solution but it will take time until it is more and more adopted.

Same with hkp://, unfortunately:

2019-01-28 19:11:08 gpg[4536] DBG: chan_0x0000011c → KEYSERVER --clear hkp://
2019-01-28 19:11:08 gpg[4536] DBG: chan_0x0000011c ← OK
2019-01-28 19:11:08 gpg[4536] DBG: chan_0x0000011c → KS_SEARCH – E21E2C3E
2019-01-28 19:11:10 gpg[4536] DBG: chan_0x0000011c ← ERR 219 Server zeigt einen unbestimmten Fehler an
2019-01-28 19:11:10 gpg[4536] error searching keyserver: Server zeigt einen unbestimmten Fehler an
2019-01-28 19:11:10 gpg[4536] Suche auf dem Schlsselserver fehlgeschlagen: Server zeigt einen unbestimmten Fehler an
2019-01-28 19:11:10 gpg[4536] DBG: chan_0x0000011c → BYE
2019-01-28 19:11:10 gpg[4536] DBG: [not enabled in the source] stop


Another thing that changed between 2.x and 3.x was IPV6 and added TOR support.

For me (on linux) it works flawlessly.

$ gpg --keyserver hkp:// --search E21E2C3E
gpg: data source:
(1) Patrick Brunschwig

I will try it on windows but expect the same results for me.

It does not work with version 2.2.6, but with 2.2.5. Just tried without internet connection: exactly the same error message. And (with connection) I do not see any traffic from gpg --keyserver hkp:// --search E21E2C3E, i.e. I would expect some outgoing question to hkp:// and some answer from the server, but there is 0 traffic (and no firewall-alert about an unknown program).

On windows it also works. (But it took a while):

C:\Users\aheinecke>gpg --keyserver hkp:// --search E21E2C3E
gpg: data source:
(1) Patrick Brunschwig

^ So no surprise on windows. Server server shows an “undefined” error, does not mean a much to me. It’s basically “Computer says NO!”,…

You might want to try to kill the “dirmngr.exe” process (Have you tried turning it off and on again?) through the task manager. That is our network communication process (In an isolated subprocess for security reasons). Maybe that helps. In an ideal world that should not be necessary though.

Next steps would be to look at your Firewall, Network stuff, ports on your local machine etc… It seems like a “setup specific” problem to me.

I wrote my last comment before seeing your message from 18:27 I’ll have a look about what changed between those two versions. My stomach feeling is that it might have been IPv6 support.

I do not understand this. Gpg4win-2.2.5 Shipped with GnuPG 2.0.28

Gpg4win-2.2.6 Shipped with GnuPG 2.0.29

The Changelog for GnuPG in between is:

Noteworthy changes in version 2.0.29 (2015-09-08)

  • gpg: Print a PGP-2 fingerprint again instead of a row of “0”.

  • gpg: Fixed a race condition from multiple several “gpg --verify”.

  • gpg: Print FAILURE status lines to help GPGME.

  • gpgsm: Fixed a regression in CSR generation.

  • scdaemon: Fixed problems with some pinpads.

  • Fixed a few other bugs.

Nothing regarding the Network. Are you sure that you are properly restarting everything between your tries? Our installers are not so great that they catch every process for sure. So I have some concern that you install 2.2.5 > works > 3.1.5 (which would kill all processes) → Reinstall 2.2.6 → Still have a 3.1.5 Dirmngr running because the 2.2.6 installer wars not so good.

…OK, thanks! Uninstalling GPG4Win, restarting Windows, deleting the install-directory, installing 2.2.6: works indeed. I’m trying versions between 2.2.6 and 3.1.5 now.

The big split not only in GnuPG but also in installer code is between 2.x and 3.x

E.g. The split is like 5 Years of development in GnuPG; it is very large for us internally.

Yes, it is 2.3.4 working, 3.0.0 not working. While at least it is reasonable, that it happens when stepping from 2.x to 3.x, more changes make it more difficult to find a cause for the issue, doesn’t it?