gpg4win installation stalling

I’m trying to install gpg4win 3.1.0 but the installer is stalling at the point show in the attached screen shot. I’ve previously uninstalled a partial installation (that was also unsuccessful) of gpg4win so it’s quite possibly related to this. I’ve tried restarting before the installation but that didn’t improve things.

Can anyone suggest how I can diagnose or resolve this issue?



To add more detail, I’m running the installer as admin using Defendpoint to raise my privileges (I’m in a corporate environment).

Also, I was trying to install the Kleopatra, GpgOL and GpgEX optional components as well as the mandatory GnuPG component.

You could try to open a command line with privileges similar to how you open the installer and then execute the command manually:

c:\windows\system32\regsvr32 /s “c:\Program Files (x86)\Gpg4win\bin_64\gpgol.dll”

Does this command hang or work?

(You can omit the /s to maybe get output of this command.)

I don’t know how this could possibly hang but, it appears to be the case for you. This is a system call where we “register” out GpgOL plugin with Windows, so that Outlook can load it.

As a workaround you can probably abort the failed installation and then try again without the GpgOL component selected. Depending on weather or not the regsvr command worked you might not have GpgOL in Outlook.

This command runs without complaint (leaving out the /s).

I have inadvertently discovered that if I try to restart my PC while the installer is stalled but then select ‘cancel’ when asked if I want to go back and save unsaved work, this seems to nudge the installer into giving an error message about failing to register the DLL and carrying on. It then stalls again while trying to register the shell extension DLL. This stalled state can again be overcome by almost restarting.

I’m not sure if this will help but it at least let the installation finish for me, albeit with the two registation errors.