GPG4win decrypt_message failed

Hi. I’m running this on Windows 2008R2. My batch command has worked flawlessly till I upgraded to GPG4win v2.2.1. Kleopatra decrypts just fine. Here is the command line and what it gives:
“C:\Program Files (x86)\GNU\GnuPG\gpg2.exe” --passphrase “mysecuritykey” --batch -r E53D9EF1 --output “c:\ftp\vendor\Decrypted\dailyfile.txt” -d “C:\ftp\vendor\process*.pgp”

New unwanted result:
gpg: can’t open `C:\ftp\vendor\process*.pgp’: No such file or directory
gpg: decrypt_message failed: No such file or directory

If I need to reinstall a lower version, that is an option. The only reason I upgraded was Kleopatra was being flakey. Thanks

This looks like

Best Regards,
ps.: Like my response?
I appreciate if you flattr Gpg4win at Thanks!

Hi Bernhard. Thanks for the response. It sounds like a downgrade is the only option as this command worked fine before the upgrade.

A fix is on the for 2.2.2, it is not sure yet if it will make it in, thought.

OK, if I don’t see anything by the end of tomorrow, I will downgrade for now. Thanks guys for identifying the issue and working on it. Pretty cool community.

I would go back to the version that worked until the wildcard issue is fixed. Otherwise you can capture all the file names in the folder and then write a process to step through them one at a time and decrypt each one. I don’t think you will have a problem if you don’t use the wildcard.

The problem with downgrading is that usually the new Gpg4win version have security issues resolved.