Gpg4win 3.0 - unable to change homedir

I updated my system to v 3.0 and since I can’t recover my keyring.
I understand that the new gnupg 2.0 has changed the way to manage keyring, but I can’t get it to read my old secring and pubring to be upgraded.

I had my old config with the gpg homedir on another drive. The gpg.conf file and the registry keys were and are still pointing to that drive.

But with the new gpg version, gpg --help display shows that the homedir is pointed to the windows user default \AppData\Roaming\gnupg.

I can’t figure out how to restore the proper path of the gnupg to my drive.

I was eventually able to find a working solution by adding in the \AppData\Roaming\gnupg folder a gpg.conf file with the homedir option.

However, the automatic conversion of my secring did not occur and I had to upload it manually. After this upload they were properly installed in the \private-keys-v1.d folder.

Still, I would like to know why the registry or environment variable are disregarded and I had to revert to that solution.

Dear Patrick,

good that you have figured out a solution.

To your question: How did you set the home directory?
(The two methods that work should be:
a) using a registry setting
b) using an environment variable.)

Best Regards,

The problem is that neither of these two methods works with the latest release…

Is this the same Issue as in ?

Indeed I can confirm that it no longer works. It was a bug which I fixed now.
The registry keys HKLM/Software/GNU/GnuPG Homedir and HKCU/Software/GNU/GnuPG Homedir will be respected in the next Gpg4win version (which will come soon) again.