Gpg4Win 2.3.1

I installed this version and straight away had probs. Kleopatra would not start with Outlook 2010 32 bit, on Win 7 x64. Many installs, uninstalls and boots later, STILL no joy.

I reinstalled 2.3.0 and straight away, Kleopatra autoruns.

Hope this helps.


No problem here, but, because I saw your comment first, I thoroughly uninstalled 2.3.0 using Revo Uninstaller, first making sure that the service dirmngr was stopped and the process gpg-agent.exe killed. This method makes sure that all relevant folders and registry keys are deleted.

I rebooted and then installed 2.3.1, without incident. Because of the thorough uninstallation, I had to load my encryption keys again. The only difference from you is that I am running Win 8.1 P x64. I am also using Giegerich’s gpg4o, rather than gpgOL.

Oh, This was actually a bugfix ( ). Kleopatra is now started on demand the first time GpgOL needs it and not always.

André, many thanks for that information. Could it be placed in the readme as other users might not be aware of this change in behaviour. Personally, it was a very rare occurrence that the loading of Kleopatra/GPA caused a problem. Thanks for the fix anyway :-).



I tried 2.3.1 again, and there was nothing I could do to make the plugin load at all. I have gone back to 2.3.0 which works perfectly and will check forthcoming updates for fixes.



Oh my apologies! I think I misunderstood your Problem description.

Now I think you were reporting which is a pretty bad bug which is causing us to rework our release procedure a bit to ensure that this would have been caught.

Also we’ll move forward a 2.3.2 release to fix this.

Thanks for reporting it and apologies again for misunderstanding you :frowning:

With 2.3.2 (released today) this problem should be fixed.

Apologies for the problems and thanks for your feedback / report.

did you have a change to try 2.3.2?
What was your experience?