gpg-agent and --no-grab option on Windows 7 Pro 64bits


when I put the “–no-grab” option in the gpg-agent.conf file, the gpg-agent.exe binary won’t launch with the following error:

C:\Program Files (x86)\GNU\GnuPG>gpg-agent.exe
gpg-agent[1076]: C:\Users\nikolaii\AppData\Roaming\gnupg\gpg-agent.conf:3: invalid option

However, this option is present in the help:

C:\Program Files (x86)\GNU\GnuPG>gpg-agent.exe -h
gpg-agent (GnuPG) 2.0.17 (Gpg4win 2.1.0)
libgcrypt 1.4.6


 --server                     run in server mode (foreground)
 --daemon                     run in daemon mode (background)

-v, --verbose verbose
-q, --quiet be somewhat more quiet
-s, --sh sh-style command output
-c, --csh csh-style command output
–options FILE read options from FILE
–no-detach do not detach from the console
–no-grab do not grab keyboard and mouse
–log-file use a log file for the server
–use-standard-socket use a standard location for the socket
–pinentry-program PGM use PGM as the PIN-Entry program
–scdaemon-program PGM use PGM as the SCdaemon program
–disable-scdaemon do not use the SCdaemon
–keep-tty ignore requests to change the TTY
–keep-display ignore requests to change the X display
–default-cache-ttl N expire cached PINs after N seconds
–ignore-cache-for-signing do not use the PIN cache when signing
–no-allow-mark-trusted disallow clients to mark keys as “trusted”
–allow-preset-passphrase allow presetting passphrase
–enable-ssh-support enable ssh-agent emulation
–write-env-file FILE write environment settings also to FILE

Please report bugs to

What’s the problem?

Thanks for your help.

Never mind, I found by myself: the option doesn’t require two hyphens at the beginning, the option thus must be written like this in the configuration file: “no-grab”

However, this option isn’t taken into account by the “pinentry” process, so this isn’t very helpful …