GPA error,


I’m trying to use the gpg4win 2.0.0 tool. English-language docs are not avail yet. Looked at the Novice pages. Created a test key. Sent message to Adele. Pasted Adele-encrypted text below into the GPA Clipboard. Clicked Decrypt. Entered my pass-phrase. Next the error message comes up

“Error in operation result: No valid UTF-8 at position 42”.

Please advise. What do I do wrong? I want to use the tool to do rudimentary encryption/decryption of email messages and small files.

Thank you,

I’m getting almost exactly the same message, although in my case it’s:

No valid UTF-8 at position 44

I’ve taken the text from Adele and converted it to a range of formats, UTF-8 with and without BOM and ASCII. The error message from GPA remains the same. I’ve uninstalled gpg4win rebooted and reinstalled it, same crap.

This is on WinXP SP2.

So then I tried Gnupg Shell. That was a truely horrid experience too. There’s a Windows installer but the documentation is nonexistant. There is a monolithic man page file which is basically a dump of a load of Unix style command line help, what a great way to teach your users how to use a program pfft. Apart from that there’s a link to a webpage that in terms of documentation has basically nothing apart from a few short silent videos of a guy performing some basic tasks on a desktop in Russian.

Nevertheless after more farting about I was able to import the key I generated with Ghp4Win into Gnupg Shell, and after even more farting about it did actually correctly decrypt the message from Adele, so I’d say it’s fairly cut and dried that it’s Ghp4Win that’s fubar in this respect.

Gnupg Shell itself seems utterly pointless though. There is no encrypt/decrypt to or from clipboard, or even a text window you can do this in. So you have to manually take your encrypted text, put it into a standalone file, give this file a custom .gpg file extension because that’s the only way Gnupg Shell can work out whether it’s encrypted or not and without it none of the UI controls are enabled (lol). Then launch a ‘File Manager’, then locate the file, select a key to use for the decryption process, press decrypt, type in the passphrase. Then Gnupg Shell decrypts the file and puts in in the same directory as the input file but with no extension at all, so then of course you have to manually add an extension to the file so that you can actually open and read it.

So all in all Gnupg Shell takes at least as long to do anything than if you’d just used the commandline Gnupg. It’s not remotely configurable or imo usable.

The PGP Corporation has jack, all they have now is some ‘trialware that isn’t trialware but that still unencrypts everything you’ve encrypted during the trial period and then partially runs as crippleware and which you can’t use for commercial purposes anyway’ rubbish.

So does anyone know of any other PGP program for windows that works and has a reasonable UI? I only need to send a quick email to the bank and I seem to recall that a few years ago PGP was something free and simple that worked. I thought I’d install something and be done in 20 minutes, instead it’s like I’ve wandered into an alternative reality where the only software available is worse than what we had ten years ago and/or doesn’t work at all.

In the time I’ve spent farting about with this (all afternoon) I could probably have written a Python/Mono/Dotnet frontend to Gnupg myself and have something that works by now. Sigh, one more project for the list I guess.

Fyi I’m now using WinPt. Seems small and efficient. Can encrypt/decrypt directly in your editor window with no messing about with clipboards or files.

Written by Germans and some of the documentation is iffy and the file types it defines have German names, but the program is strightforward to use and file type names can be changed in Folder Options.