GnuPG Newbie getting started - GPA error msg

I have downloaded and installed gpg4win-1.1.4. on my Win XP PC.
When I tried running GPA from the start menu the dos window briefly appeared and then the following attention message box appeared:-

GPA Error

Fatel Error in GGME library
(invoked from file /home/wk/src/gpg4win11/build/gpg4win-1.1.4/src/playground/build/gpa-0.8.0/src/confdialog.c line 1447):

Unsupported protocol

The application will be terminated

I uninstalled, re-downloaded and reinstalled but still had the problem.

Can anyone help?



I received the same error message when I tried to use GPA on my Vista Ultimate laptop. I can use WinPT [Windows Privacy Tray] to generate keys, etc. Try that.

To add you might look at GPGshell as an alternative to WinPT or GPA.

Thank you for all your help.

Sorry I’ve not responded sooner.Currently I am not able to get to my PC very often or for long.

I will try out your suggestions as soon as I can. Although I think there is something fundamentally wrong because my Firefox addon FireGPG can not find the executable, even when I explicitly specify the path in the options.

Thanks again.

Best Regards,


For all this to work, ie. WinPT or GPGshell you need a working gpg4win. What I would recommend is…

As an administrator [these are examples from a Vista laptop]…

  1. Uninstall gpg4win
  2. Reboot the PC
  3. Verify the c:\program files\gnu folder is deleted. Manually delete if not.
  4. Very Very carefully search the registry for Gnu and gpg4win entries. Look in HKEY_LOCAL_MACHINE\SOFTWARE\GNU and delete that path. Also look in HKEY_CURRENT_USER\SOFTWARE\GNU and GPGee and delete those.
  5. For each standard/limited user run regedit and delete HKEY_LOCAL_MACHINE\SOFTWARE\GNU and HKEY_CURRENT_USER\SOFTWARE\GNU and GPGee.
  6. As an adminstrator go into the Control Panel → System → Advanced System Settings → Environment Variables. Scroll down and highlight System variables → Path and select Edit. Carefully delete any entries for C:\Program Files\Gnu and click OK.
  7. Reboot the PC.
  8. Reinstall gpg4win using the latest version.

Thanks Sooner Al.
I managed to get to a wireless connection point last night and try out your WinPT suggestion.
It worked! So that’s great I can exchange encripted messages and have done so with my son.
I’m about to move on so it could be a few days before I can get on the internet again but I suspect there is something wrong with my installation for other programs to fail; so I’m keen to try out your suggestions for reinstalling and setting the registry.

All the best,


Good news. Glad its working for you.

Be aware I have the same issue as you, ie. GPA does not work and results in an error condition, so just reinstalling at this point probably will not fix the GPA issue. I only suggested a reinstall if WinPT also failed. Since you can use WinPT your good to go. Look at GPGshell. I am using it versus WinPT and like it a whole lot better.

FWIW, here are a couple of related threads on the Gnupg-users mailing list you or others may be interested in…

The entire archive which can be a very useful source of information.

There is a bug in gpg4win 1.1.4.

The installer does not force the installation of GnuPG 2 which is now a requirement for GPA.

Please download and install the GnuPG 2 component.