Files encrypted with Gpg4win are decrypted as text files by Symantec


I’ve been encrypting some files with Gpg4win 2.2.1 and sending them to my co-worker (who uses Symantec Desktop Encryption 10.3.1) but when she decrypts them they show up as text files. The encrypted files I’ve sent have been:

  1. A single Excel spreadsheet encrypted with OpenPGP.
  2. A set of four spreadsheets, encrypted via OpenPGP using Gpg4win’s TAR archive feature.
  3. A ZIP file containing the four spreadsheets but encrypted as a single file using OpenPGP.

I have sent the files two times, first with their original “.gpg” extension and then a second time after changing the extension to “.pgp” but both times the decrypted files are listed as text files. The files themselves seem uncorrupted because, if she changes the resulting file’s extension to what it should be (i.e. “.xls” or “.zip”), the resulting file is the one I originally sent.

Is this a result of a bug in Gpg4win or Symantec’s software, and is there anything I can do to resolve this issue? I’m working to implement Gpg4win within my company, and interoperability with Symantec’s software is probably the most important requirement for this implementation to be successful.

Please let me know if there’s any more information you need me to provide relating to this issue. My co-worker and I both use Windows 7 Professional.

Thank you,

What does the file name look like after you encrypt it? i.e. FileName.xls.gpg or FileName.gpg? If it is the former then my guess is that your Symantec settings need to be changed for decrypting to just strip off the .gpg (last 4 characters) when decrypting and not default to .txt as the extention.

When I send the file it has the format “filename.xls.gpg” and after Symantec Desktop Encryption tries to decrypt it the resulting filename has the format “filenamexls.txt.” The same thing happens when I change the sent file’s extention from “.gpg” to “.pgp”

Symantic is replacing the last 4 characters of the file name with .txt. You need to find out where that default setting is and change it to remove the last 4 characters instead of replacing them with .txt for the output of the decrypted file. I am assuming if you manually rename the file and change the extension to .xls (remove the .txt) all works fine.

Hi, appreciate this has been a while now since opened. Did you ever get a workaround or resolution to this? We have exactly the same issue… Thanks in advance