Error with right-click > Sign and Encrypt

This problem started for me with v13 and I had to go back to v11. I have now tried v15 and still get the same error, so I thought it worth reporting.

Right-click on a csv file > Sign and encrypt > I select ‘Encrypt for others’ and click Sign/Encrypt

It pops up a message “The file …csv.gpg already exists. Overwrite?”

(The encrypted file did NOT exist before I started this process)

I click ‘Overwrite’ and get error

“Kleopatra: Could not remove file “//server…csv.gpg” for overwriting.: Input/output error (218136625)”

Checking, I find that the encrypted file actually exists with what looks like a random text suffix. I remove that and decrypt the file and it is all OK.

While documenting the above I noticed that I was encrypting a file on the network. So I tried again with a local file and that work fine.

So it looks like a permission issue with a network file. But I have full permissions on the file and folder in question. And v11 works fine. So this is not really a permissions issue but some bug.

Hi Les,
thanks for reporting.

What find of network drive are you using?
(The next step is to reproduce this for developers, so they can work on a fix.)

So the problem seems to have been introduced with 3.1.12, the changelog lists a couple of changes in the area of file names and file name suggestions.


The data is on my server and I access it from file Explorer as:


Then right-click on one of the files in the list.

I just tried it using a mapped drive letter (Z:\xx\yyy) and it was fine.

Hi Les Dee,
this sounds a lot like a problem caused by
and thus should be fixed with the next release.


Thank you. I’ll keep an eye open for the update.