Encrypt in Kleopatra on Windows 11 is broken.

I’m quite tech savvy to start. I installed the latest version of Kleopatra and created a new RSA 4,096 key with pass phrase.

Another system used my public key to send me a message, put that message in a file and decrypted the file successfully, ok we’re off.

So to test this I decided I should encrypt and decrypt a message to myself to make sure everything is working. I encrypt the clipboard and select myself as the recipient, I paste that into a file to verify it looks good, BEGIN PGP ENCRYPTED MESSAGE, ok so far so good.

I go back to Kleopatra and in the Clipboard menu decrypt is grey. I try to decrypt the file, no it tells me it cannot determine what it is?

Now, if I use my public key to encrypt using a website (https://8gwifi.org/pgpencdec.jsp), I can decrypt that output from a file or from the clipboard in Kleopatra! I tried the same website, encrypt and decrypt using my public and private keys and that works fine. I encrypt with Kleopatra and try to decrypt using the site… nope it will not decrypt the text encrypted with Kleopatra. It also works fine in GnuPGK which I found online, except if I encrypt with Kleopatra that won’t decrypt it either.

The text from Kleopatra encrypt looks like this:



It does not include version info. I tried an older version of Kleopatra, 3.1.16, same thing. I am selecting RSA and RSA+ when I create my key but I don’t think the key is the issue as it works fine on the website.

EDIT: If I use the Notepad feature in Kleopatra it encrypts and decrypts fine. If I encrypt with the clipboard Encrypt feature it does not decrypt in Notepad or from Clipboard, if I encrypt with Notepad it will decrypt from clipboard. Encrypt in Kleopatra on Windows 11 is broken.

Just tested Gpg4win 4.1.0 on Windows 11.

Encrypt in Notepad → Decrypt in Notepad: Works
Encrypt in Clipboard → Decrypt in Notepad: Works
Encrypt in Notepad → Decrypt in Clipboard: Works
Encrypt in Clipboard → Decrypt in Clipboard: Works

Tested with an ECDH key and did the test “Encrypt in Clipboard → Decrypt in Notepad” also with a RSA key.

Did you select the correct recipient?

Yeah my own key, the same one that works on the website and GnuPGK.

The Clipboard->Decrypt menu is grey when I use Clipboard->Encrypt, paste it into Notepad and copy it to make sure it’s correct, and if I paste it to a file it tells me the file isn’t recognised when I use File->Decrypt and asks me if it is a detached signature or an archive. These both work fine if I encrypt using the same key and GnuPGK or the site.

This is the content it says it cannot decrypt from a file and clipboard decrypt is grey.



When I copy your content I can use the Decrypt entry in the clipboard menu. Then is just says “Decryption failed: No secret key.” When I put the content into a file it’s the same result. It’s like I would expect it.

It must be something else. Kleopatra is definitely working. Maybe you save the key in the file with a special encoding? Or are you using other tools that have access to your clipboard?

It was happening for both file and clipboard. I just rebooted my machine, deleted my key and made a new one and now everything works :expressionless: I don’t know what to say. Thanks for your time I appreciate it.

I’m glad to read that it is working with the new key :slight_smile: