Email Decryption Issue

One of the recipient is not able to decrypt the emails I send him using his public key.
I use gpgOL(Kleopatra) to encrypt emails, while he is using “Symantec Desktop Encryption” at his side for deception.

He is just able see a blank email with an attachment called ‘GpgOL_MIME_structure.txt’ . Email screenshot attached for reference
can anyone please help me fix this issue?

Sample Error.JPG


when you open the settings → GpgOL there is a section probably called “General” and the fourth option enables PGP/Inline. Maybe Symantec Desktop Encryption does not support PGP/MIME so you could try to activate this option and then send an email.


Trying the deprecated no-mime format is worth a try to see if this changes anything.
As far as I know Broadcom’s Symantec dies support OpenPGP/MIME.

The other possibility is that you’ve created a default keypair with the new algorithms
using elliptic curve cryptography (ECC) and your communication partner’s cannot deal with it. To check, see the detailed properties of your keypair. Try with an RSA 4096bit keypair, if you run in this problem of backwards compatibility.


Thanks Christoph.
Tried this setting & emails without attachments work But emails with attachment doesn’t.

Any possible workaround?

What happens if you try to send emails with attachments?

Have you tried a different key like Bernhard suggested? I remember that I created a key with Gpg4win (a version after the default key type was changed) for testing purposes and couldn’t import it in Thunderbird. So that could be a cause for that problem.

Hi Bernhard,

Sorry but, I Could not understood the first part of your message. Can you elaborate a bit more please. (ex- where can I find that setting etc…)

I tried the second part to update my keypair to RSA 4096bit,but no change in the behavior.

Though emails without attachments started working when I enabled PGP/Inline suggested by Christoph.


Tried regenerating my keypairs to RSA 4096bit,but no change in the

Hi Gopinath,

“PGP/Inline” is an option that enables a behaviour which is an old format
as it cannot do MIME, I often call it deprecated no-MIME.

Maybe the used PGP version from your sender is very old?

Is is possible to save the attachement and then open it?