Decrypt/verify doesn't ask for passphrase, then decrypt operation fails

I created a key pair yesterday and sent the public key to a colleague. As a test, he sent me a test.txt.gpg file. I haven’t been able to decrypt it. I right-click the file, click “Decrypt and Verify,” leave the default settings (“Create all output files in a single folder”), and then click Decrypt/Verify. The program never asks for my passphrase, and on the Results screen it just says “test.txt.gpg → test.txt: Decryption failed: Decryption failed.” Does anyone know why this is happening?

You have your colleague’s public key in your keyring?

I don’t have his public key. I sent him my public key. He encrypted a text document and sent it back to me. According to the documentation, I should be able to open it.

Hi Sylvia,
did you try to make some tests with the robot Adele (
You send your public key to Adele in a .asc file, then he (or she…) will answer you also with his public key, that you should import; then you can try to test encryption.
It is a good option to sort out the issue between your side or partner side (Adele is supposed to work fine !)

To be sure: you do have the private key on your default keyring, right?

To check, you can open Kleopatra and right-click the key in question, then click “Certificate Details”. Under the “Overview” tab, there should be an entry that says, “Certificate type: (secret key available)”.

Alternatively, in the command prompt:

C:\Users\Owner>gpg -K
(Note: Capital K)

…and look for the ID corresponding to the public key you sent.

Sean C.

I just tried Adele–I sent it an e-mail with TestForPC.asc attached. Adele responded with “Your message neither contains a public key, nor any encrypted text that I could try to decrypt. Since I only exist to help testing of OpenPGP emails, I do not know what to do with your message.”

Is there something wrong with the .asc file (I attached it here)?

TestForPC.asc (971 Bytes)

Yep, I see “Certificate type: 2,048-bit RSA (secret key available)” in the Certificate Details screen.

By the way, I just tried Adele again.

I created a new key. I exported the key from Kleopatra, named it Test2ForPC.asc, and then attached Test2ForPC.asc to a new message and sent it to Adele. I got the same message as last time (“Your message neither contains a public key, nor any encrypted text
that I could try to decrypt.”).

I created another new key. When I exported the key from Kleopatra, I didn’t change the name this time (see the attached file). I attached this key to an e-mail and sent the e-mail to Adele. Same result.

Is there something basic I’m missing here?

63045A4F17C72483AF2C247876726950320522B3.asc (971 Bytes)

I was able to successfully import both keys. Everything looks kosher on my end.

Adele is good, but not the ideal testing solution. Have you tried including your key in the body of the message instead of as an attachment? Just copy the text from the .asc file and paste it into the email.

Alternatively, I could try sending you a message.

Sean C.

I just tried sending my key to Adele and got the same response. Oddly, though, the response was encrypted with my key.

Have you uploaded any keys to a keyserver? If so, try sending Adele a message encrypted with “her” key (attached) and see if you get a response. That worked for me.

But remember: once you upload a key to a keyserver, it cannot be removed. Be prepared to revoke it if necessary.

Adele.txt (96 KB)

I imported your test3forPC public key in Kleopatra, worked fine too. With this public key, I encrypted a text file, here attached. Sylvia, you should be the only person on this planet to be able to read it, using the private key of this certificate…
Would you decrypt it ?

qbf.txt.gpg (374 Bytes)