Comman line

I printed out “GPG --help”, searched online and even tried to figure out the command line arguments from other posts, but to no avail. Is there any detailed documents on the command line as --help is not helpful

MY SCENARIO: I have imported and trusted a cert from another party, and have also created one for me. Through windows (right mouse click on a file) I am able to encrypt using their cert and sign with mine.

I am unable to get the command line to work at all. Sometimes an error, most times not. How should the command line look?

Reading another post regarding the command line, they were using gpg2, where as I am using gpg. Whats the difference?

Here is what I currently have (dos.cmd file):
echo {the passcode}|gpg --batch --passphrase-fd 0 --output thefile.txt.pgp --encrypt “xxx.asc” --sign “yyy.asc” text.TXT

I have also tried the encrypt and sign with the name, still no workie.

Getting an error about --encrypt [filename] syntax error.

I was able to work when I just had 1 cert when I was playing.

Any help would be appreciated.


Try this web site:

Also usually you are encrypting a txt, csv, doc or xls file. Why are you encrypting an asc file? I would expect something like --encrypt the_file.txt based on your output file name.

I went through many revisions trying to figure it out and copied the current one.

I took the --encrypt as the key to use for encryption.

I am trying to, through script, encrypt with one key and sign with another. I will take at look at the link THanks,

–encrypt is the file you are encrypting. --Output is the result file name.

Also -r is where you put the ID of the recipients public key that you imported on to your keyring.

| Is there any detailed documents on the command line

Yes, it comes with the manual of GnuPG (and is installed by Gpg4win somewhere I don’t remember out of the top of my head)
You can get an online version at
(note that his may slighty variy from your specific version)

| they were using gpg2, where as I am using gpg. Whats the difference?

On most machines, gpg is an alias of gpg2. With gpg2 --version or gpg --version
you can see which version you have. On rare occasions gpg and gpg2 are two different versions and gpg refers to GnuPG 1.4.x. To be more explicit many examples use gpg2 to be sure to have the new and recommended version.

they work pretty much the same. gpg2 might have something extra that gpg does not but all the commands I have used so far work in either. I started out with gpg but upgraded to gpg2 (gpg2 definitely had no problems running anything I built for gpg). I would recomend using gpg2.