Certificate is loading

I have installed gpg4win-3.0.0-beta258.exe on my Windows 7 system.

So when I start now Kleopatra with my “standard account”, he is loading the “certificate-mean-safer”. After 8 minutes I closed the process manually. Please see the attachment.

But when I start Kleopatra as Administrator it works. After few seconds he has loaded the “the certificate-mean-safer”.

Question: Can I only use Kleopatra as Administrator?


Dear Jan,
thanks for trying a Gpg4win beta in the first place.

Did you install Gpg4win as administrator oder user?
Do you have any private or public keys on the machine from a previous install?

You could try to see if
gpg2 -k
gpgsm -k
both work.

Best Regards,

Hello Bernhard

Thank you for your reply.

-I do no more know if I have it installed as unser or admin. But I guess I have simply doulbe clicked the setup.exe, so I guess it was as user.
-Please have a look at the attachment “gpg4Win Installation.PNG”. As here there was no file installed in Users\Admin, I guess this is the proof that I had really installed it as user.

This was not my first installation of Gpg4win beta. I had already installed “Gpg4win beta of an earlier version”. So, yes, with the earlier version I had already created any certificates.

I did not found gpg2 anywhere on my harddisc. But I found gpgsm in “C:\Program Files\GnuPG\bin”. So I opened cmd as administrator. I changed to “C:\Program Files\GnuPG\bin” and I typed in “pgpsm -k”

This was the result:
C:\Program Files\GnuPG\bin>gpgsm -k
gpgsm: It is only intended for test purposes and should NOT be
gpgsm: used in a production environment or with production keys!

Best Regards,

gpg4Win Installation.PNG

Hi Jan,
thanks for helping us to test the latest beta.

It should be able to work with just a user install,
but there may be defects. I did try beta258 as user install on a fresh virtual
machine and did not see your problems.

Please type
gpg -k
on a cmd.com window to see if it already finds pubkeys from you.
Maybe there is some permission problems from an elder install where you
did install as admin, but this is just a guess.

ps.: the new beta259 should not behave differently in this point (I guess), if this worked fine in an older beta you could try to go back one and see if this works better for you.

Hi Bernhard

gpg -k: Please look at the attachment to see the result.

I had already problems with the elder beta install. And I had also (but other) problems with the latest stable (not beta) version. (installing problems).

As I wrote, the described problem of my first post does not accur when I start it as administrator.

But there is still another problem with beta 258, which I have not mentioned until now. It occurs also when I start it as Administrator:
When I go to
File->new Keypair->create a personal OpenPGP key pair,
then “Creating Key” dialog never ends. After more than 2 housr I aborted the process manually.

When I make a right click on the icon when Kleopatra is open and click to shut down, then I go to the task manager: There i find still GnuPG’s processes? Is that normal. Shoudn’t this process be closed when I shut down Kleopatra?

The processes are:


gpg -k.PNG


In the mean time I was able to solve this problem:

  1. I opened Kleopatra as Administrator.
  2. I deleted all keys.
  3. I shuted down Kleopatra and after I closed all open gpg procresses in the Taskmanager.
  4. I opened Kleopatra as user.
    Now other keys appeared.

→ Now it works. It loads the keys within a few seconds. Also I can now make new keys. As far it works.

It is normal that many processes stay open, even Kleopatra leaves its process open in case of malfunction. To correct this; I use 2 batch files to get rid of any left over processes. Some other user in this forum had the idea an started the batch file. I just added new processes, deleted obsolete processes and the second file for gnupg , but maintenance could be necessary again. I attach the two files that should be placed in the appropriate directories.

I could only add one file so here is Task_Close_gpg4win.bat:

taskkill /F /IM gpa.exe
taskkill /F /IM kleopatra.exe

Task_Close_gnupg.bat (420 Bytes)

Thank you for sharing @Andreas.