Certificate expired


I’m trying to push my key to a server.

An error occurred while trying to export OpenPGP certificates.
The output from
C:\Program Files (x86)\GnuPG\bin\gpg.exe was: gpg: sending key 541C171F37006ABE to hkp://keys.openpgp.org gpg: keyserver send failed: Certificate expired gpg: keyserver send failed: Certificate expired

So you say - it’s expired!

But I just created it.

Comment: User-ID: Al Manint al.manint@gmail.com
Comment: Created: 10/8/2021 3:09 PM
Comment: Expires: 10/8/2023 12:00 PM
Comment: Type: 3,072-bit RSA (secret key available)
Comment: Usage: Signing, Encryption, Certifying User-IDs
Comment: Fingerprint: 21265268FD759144473B27D3541C171F37006ABE

Am I doing something stupid? (probably) Before the Key Network went it worked. This is from my house - not work - so there are no obvious firewall issues…


I exported the public key and uploaded it directly on the website and it worked. Still not sure what the issue was with gpg locally because the key looked right.

Hi Al,

it is very likely that you are running into a problem with the TLS certificate
of the server and a peculiar way that Let’s encrypt has handled a transition.
The part of Gpg4win that is handling the keyservers: GnuPGs dirmngr
could not deal with the special cross signature.

This has been corrected with GnuPG 2.2.32,
one way to remedy this is to use the binaries from here to update the GnuPG
that is coming with Gpg4win 3.1.16:

For more (technical) details, see
and https://lists.gnupg.org/pipermail/gnupg-announce/2021q4/000465.html

Sorry for the hassle, this effect came a bit unexpected.


Thank you - that makes sense - I’ll probably test it out of curiosity when the bits drop.