Can't import a certificate from key server

Good morning,

In Kleopatra, I can “Lookup on server” and find a certificate in the server. I select the certificate and press “IMPORT”. After that a pop up appears but with the message "Total number processed:0 " and “Imported: 0”.
I noticed that nothing was imported to the Kleopatra.
But if I use the command line (gpg --keyserver --search-keys XXXX XXXX XXXX XXXX XXXX …) is possible to import the certificate.
How can I import certificates from the server with the Kleopatra? What would be the problem here?

Thank you for your help.

In the menu settings:
directory services in the field “OpenPGP keyserver” put “hkp://servername/”
In GnuPGSystem → separator OpenPGP → “Use keyserver at” put “hkp://servername/”.
In GnuPGSystem → separator Network → “Use keyserver at URL” put “hkps://servername:11371”.

Should work.

Hello Fabio,

as Kleopatra uses GnuPG as its engine, I don’t know where the difference is.
(The dialog could be better of course to show what the reason is why a certificate is not imported.)

If you like, you could email the keyserver and public key in question to and I could try.
(if you do not want to publish the public key here.)

Best Regards,

Hello Bernhard,

thank you for your answer.
I already solved the problem doing this configurations in Settings->configure kleopatra:
Separator “directory services” in the field “OpenPGP keyserver” put
In separator “GnuPGSystem” → separator OpenPGP → “Use keyserver at” put
after that it works fine.
Just need to put the URL address and not an IP address.

Thank you.

Best regards.

Hello Bernhard,

just to update this question.

if I put in the configurations in Settings->configure kleopatra the url like this:

It will not be possible to import the certificate.

But if I put like this:

The problem will be solved.

So, the problem appears when we specify the port and not the protocol.
The same with the https.
If I put “http://servername:443
It will not work well,

but if we insert the protocol like this

should work fine.



thanks for the feedback!

I wonder if this should be reported as a minor problem.
(There seems to be a small usability problem,.)